mpc85xx: Use gzip compressed kernel on HiveAP-330
authorPawel Dembicki <paweldembicki@gmail.com>
Thu, 4 Jul 2019 11:17:02 +0000 (13:17 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sun, 7 Jul 2019 11:02:05 +0000 (13:02 +0200)
After commit 1e41de2f48 ("mpc85xx: convert TL-WDR4900 v1 to simpleImage")
XZ compression of zImage was enabled. This change exposed a problem with
the HiveAP-330 images, which was fixed by foregoing the compression on
the kernel altogether with commit 98089bb8ba8
("mpc85xx: Use uncompressed kernel on the HiveAP-330").

This patch adds back the gzip compression of the kernel image by
utilizing the generic OpenWRT uImage method instead of relying on
the PowerPC bootwrapper script that did it previously.

Compile-tested: p1020/hiveap-330

Tested-by: Chris Blake <chrisrblake93@gmail.com> [run-tested]
Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
[filled in even more text]

target/linux/mpc85xx/image/Makefile

index c582d7a5920d6ea424bfcd0be7fbc20119f6bbf9..c2ddcb32c5cae71b83db4a026f9cd4e53f77bca6 100644 (file)
@@ -85,7 +85,7 @@ define Device/hiveap-330
   DEVICE_TITLE := Aerohive HiveAP-330
   DEVICE_PACKAGES := kmod-tpm-i2c-atmel
   BLOCKSIZE := 128k
-  KERNEL := kernel-bin | uImage none
+  KERNEL := kernel-bin | gzip | uImage gzip
   KERNEL_SIZE := 8m
   KERNEL_INITRAMFS := copy-file $(KDIR)/vmlinux-initramfs | uImage none
   SUPPORTED_DEVICES := aerohive,hiveap-330