package/libs/zlib: Add host build
authorDaniel Engberg <daniel.engberg.lists@pyret.net>
Tue, 12 Dec 2017 14:31:59 +0000 (15:31 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 2 Jan 2018 16:11:12 +0000 (17:11 +0100)
Some packages such as Python/Python3 (host pip/pip3) needs this
to compile.

More detailed explanation provided by Alexandru:

"i need the zlib/host for Python/Python3 ; because, it seems the
host pip/pip3 needs this to work ; i suspect in older versions
this worked, because some of the host's build env would be used
in the build, and then the zlib-dev from the host distro would
be used ; now, the host-build does not seem to have any
-I/usr/include stuff, which is good

and it also seems that Python/Python3 does not like it if the
zlib-dev package is too old, so using this zlib/host would be
good for this as well"

Source:
https://github.com/lede-project/source/pull/1329#issuecomment-351055861

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
package/libs/zlib/Makefile

index 2650faa139b0aeb412ef78f7a627758904c85d66..94977b05896a14d401777f75a8d78d9fd5dbb5c5 100644 (file)
@@ -21,6 +21,7 @@ PKG_CPE_ID:=cpe:/a:gnu:zlib
 
 PKG_CONFIG_DEPENDS:= CONFIG_ZLIB_OPTIMIZE_SPEED
 
+include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
@@ -96,5 +97,6 @@ define Package/zlib-dev/install
          $(1)/usr/lib/pkgconfig/
 endef
 
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,zlib))
 $(eval $(call BuildPackage,zlib-dev))