tegra: add vendor string to device name
authorTomasz Maciej Nowak <tomek_n@o2.pl>
Wed, 1 May 2019 17:43:54 +0000 (19:43 +0200)
committerPetr Štetiar <ynezz@true.cz>
Wed, 15 May 2019 11:34:23 +0000 (13:34 +0200)
for better identification. Also create SUPPORTED_DEVICES string from it
which corresponds to dts compatible string.

Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
package/boot/uboot-tegra/Makefile
target/linux/tegra/image/Makefile

index a42d9cfc277f17d5b712d78b02803f2cc0648fa9..4b9f7876f80e4d97dda4ee38eb55af3a7c7ff7ba 100644 (file)
@@ -23,7 +23,7 @@ endef
 
 define U-Boot/trimslice
   NAME := CompuLab TrimSlice
-  BUILD_DEVICES := trimslice
+  BUILD_DEVICES := compulab_trimslice
   UBOOT_IMAGE := trimslice-mmc.img trimslice-spi.img
   SOC := tegra20
   VENDOR := compulab
index 706cc65d92e86a91212c3c71b7c9f2e80bf47078..c1aa81beddc5b44a30b5c87a3b7b54f6603ffdcf 100644 (file)
@@ -44,16 +44,16 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL := kernel-bin
   PROFILES := Default
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
 endef
 
-define Device/trimslice
+define Device/compulab_trimslice
   DEVICE_TITLE := CompuLab TrimSlice
   DEVICE_DTS := tegra20-trimslice
   DEVICE_PACKAGES := kmod-r8169 kmod-rt2800-usb kmod-rtc-em3027 \
        kmod-usb-storage wpad-mini
-  SUPPORTED_DEVICES := compulab,trimslice
   UBOOT := trimslice-mmc
 endef
-TARGET_DEVICES += trimslice
+TARGET_DEVICES += compulab_trimslice
 
 $(eval $(call BuildImage))