kernel/modules: add kmod-bpf-test package
authorTony Ambardar <itugrok@yahoo.com>
Mon, 19 Nov 2018 17:16:48 +0000 (09:16 -0800)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Mon, 11 Feb 2019 20:18:48 +0000 (20:18 +0000)
Add the test_bpf module that runs various test vectors against the BPF
interpreter or BPF JIT compiler. The module must be manually loaded, as
with the kmod-crypto-test module which serves a similar purpose.

Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
package/kernel/linux/modules/netsupport.mk

index e5362bc0703377cd6e96b833bf977ec8abcdca97..003603f10b10fb7f0effaa78ef19050ab68937b7 100644 (file)
@@ -798,6 +798,17 @@ endef
 $(eval $(call KernelPackage,sched-bpf))
 
 
+define KernelPackage/bpf-test
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Test Berkeley Packet Filter functionality
+  DEPENDS:=@!LINUX_3_18
+  KCONFIG:=CONFIG_TEST_BPF
+  FILES:=$(LINUX_DIR)/lib/test_bpf.ko
+endef
+
+$(eval $(call KernelPackage,bpf-test))
+
+
 define KernelPackage/sched
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Extra traffic schedulers