bcm53xx: fix ASUS firmwares to use vendor format
[openwrt/staging/jogo.git] / Makefile
index 0a1f96a973d7c30fb991866c11a98f39e42bc604..181c33b180f2016f6e1ce33c96b53791980ce940 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -18,6 +18,7 @@ $(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt dir
 
 world:
 
+DISTRO_PKG_CONFIG:=$(shell which -a pkg-config | grep -E '\/usr' | head -n 1)
 export PATH:=$(TOPDIR)/staging_dir/host/bin:$(PATH)
 
 ifneq ($(OPENWRT_BUILD),1)
@@ -27,6 +28,8 @@ ifneq ($(OPENWRT_BUILD),1)
   export OPENWRT_BUILD
   GREP_OPTIONS=
   export GREP_OPTIONS
+  CDPATH=
+  export CDPATH
   include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
@@ -85,14 +88,23 @@ prereq: $(target/stamp-prereq) tmp/.prereq_packages
        fi
 
 checksum: FORCE
-       $(call sha256sums,$(BIN_DIR))
+       $(call sha256sums,$(BIN_DIR),$(CONFIG_BUILDBOT))
+
+buildversion: FORCE
+       $(SCRIPT_DIR)/getver.sh > $(BIN_DIR)/version.buildinfo
+
+feedsversion: FORCE
+       $(SCRIPT_DIR)/feeds list -fs > $(BIN_DIR)/feeds.buildinfo
 
 diffconfig: FORCE
        mkdir -p $(BIN_DIR)
-       $(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.seed
+       $(SCRIPT_DIR)/diffconfig.sh > $(BIN_DIR)/config.buildinfo
+
+buildinfo: FORCE
+       $(_SINGLE)$(SUBMAKE) -r diffconfig buildversion feedsversion
 
 prepare: .config $(tools/stamp-compile) $(toolchain/stamp-compile)
-       $(_SINGLE)$(SUBMAKE) -r diffconfig
+       $(_SINGLE)$(SUBMAKE) -r buildinfo
 
 world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index