brcm2708: Add feature flag rootfs-part
authorDaniel F. Dickinson <cshored@thecshore.com>
Thu, 27 Dec 2018 03:33:57 +0000 (22:33 -0500)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 27 Dec 2018 13:06:38 +0000 (14:06 +0100)
Even with squashfs brcm2708 requires ROOTFS_PART_SIZE because the overlay
exists as a loopback device on the space not used by squashfs in the root
partition. Also for ext4 (the other fs option) ROOTFS_PART_SIZE is required,
so use feature flag rootfs-part to enable it.

Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
target/linux/brcm2708/Makefile

index 6b1991bce5f6a71acc51d3023716223c8ce44277..f4dd86767ca0e7cd28e04f50198e08d75a3860ed 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710