fstools: block-mount: fix restart of fstab service
authorKarel Kočí <karel.koci@nic.cz>
Wed, 5 Jun 2019 11:18:41 +0000 (13:18 +0200)
committerJo-Philipp Wich <jo@mein.io>
Fri, 21 Jun 2019 12:13:58 +0000 (14:13 +0200)
Restarting service causes file-systems to be unmounted without being
mounted back. When this service was obsoleted it should have been
implemented in a way that all actions are ignored. Up to this commit
default handler was called when restart was requested. This default
handler just simply calls stop and start. That means that stop called
unmount but start just printed that this service is obsoleted.

This instead implements restart that just prints same message like start
does. It just calls start in reality. This makes restart unavailable for
call.

Signed-off-by: Karel Kočí <karel.koci@nic.cz>
package/system/fstools/Makefile
package/system/fstools/files/fstab.init

index 3c318df511de0ac22c9ed98452b034239de3c765..3aa250f7d4d39a7efc0cc2a81b7d2a6d77436e8c 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
index 5faa8ecbb9bb41dd1eb3579c8abb2af9c5a34960..afed78ebfce65afd34ed194a852b748043a144ad 100644 (file)
@@ -11,6 +11,10 @@ start() {
        echo "this file has been obsoleted. please call \"/sbin/block mount\" directly"
 }
 
        echo "this file has been obsoleted. please call \"/sbin/block mount\" directly"
 }
 
+restart() {
+       start
+}
+
 stop() {
        /sbin/block umount
 }
 stop() {
        /sbin/block umount
 }