firmware-utils: tplink-safeloader: switch tl-wr1043nd-v4 to dynamic partitions
authorLucian Cristian <lucian.cristian@gmail.com>
Tue, 26 Jun 2018 17:43:28 +0000 (20:43 +0300)
committerMathias Kresin <dev@kresin.me>
Wed, 27 Jun 2018 06:42:54 +0000 (08:42 +0200)
Use the new dynamic partition split in tplink-safeloader so we no longer
have to worry about kernel size increases.

Signed-off-by: Lucian Cristian <lucian.cristian@gmail.com>
target/linux/ar71xx/image/generic-tp-link.mk
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 502c88b1bae970e0242ce6fb934911b38f4e2c7a..d78abfbba7bc1d955d1bfc4ddcc0c54f0246841c 100644 (file)
@@ -401,10 +401,10 @@ define Device/tl-wr1043nd-v4
   BOARDNAME := TL-WR1043ND-v4
   DEVICE_PROFILE := TLWR1043
   TPLINK_HWID :=  0x10430004
-  MTDPARTS := spi0.0:128k(u-boot)ro,1536k(kernel),14016k(rootfs),128k(product-info)ro,320k(config)ro,64k(partition-table)ro,128k(logs)ro,64k(ART)ro,15552k@0x20000(firmware)
+  MTDPARTS := spi0.0:128k(u-boot)ro,15552k(firmware),128k(product-info)ro,320k(config)ro,64k(partition-table)ro,128k(logs)ro,64k(ART)ro
   IMAGE_SIZE := 15552k
   TPLINK_BOARD_ID := TLWR1043NDV4
-  KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header
+  KERNEL := kernel-bin | patch-cmdline | lzma | tplink-v1-header -O
   IMAGES := sysupgrade.bin factory.bin
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
index 8cfbcd3a6748907d3965889f679300c33424337f..f048acc673e8474844b2c62e2adfa52e7b9585a5 100644 (file)
@@ -69,7 +69,7 @@ define Device/tl-wr1043nd-v4
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
   TPLINK_HWID := 0x10430004
   TPLINK_BOARD_ID := TLWR1043NDV4
-  KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header
+  KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
   SUPPORTED_DEVICES := tplink,tl-wr1043nd-v4 tl-wr1043nd-v4
index 1c3440625199cd22814f85cb32c75a0aea7a63f8..f1883cd63697ed8b4cced59d32fc420c2baca362 100644 (file)
@@ -860,15 +860,10 @@ static struct device_info boards[] = {
                .support_trail = '\x00',
                .soft_ver = NULL,
 
-               /**
-                   We use a bigger os-image partition than the stock images (and thus
-                   smaller file-system), as our kernel doesn't fit in the stock firmware's
-                   1MB os-image.
-               */
+               /* We're using a dynamic kernel/rootfs split here */
                .partitions = {
                        {"fs-uboot", 0x00000, 0x20000},
-                       {"os-image", 0x20000, 0x200000},
-                       {"file-system", 0x220000, 0xd30000},
+                       {"firmware", 0x20000, 0xf30000},
                        {"default-mac", 0xf50000, 0x00200},
                        {"pin", 0xf50200, 0x00200},
                        {"product-info", 0xf50400, 0x0fc00},