toolchain: musl: switch to https instead of git
authorChristian Lamparter <chunkeey@gmail.com>
Sun, 16 Jun 2019 11:36:54 +0000 (13:36 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 22 Jun 2019 11:17:47 +0000 (13:17 +0200)
Daniel Engberg requested switching over to https transport
since he seems to be stuck behind a corporate firewall that
does all the wrong things.

Rick Felker noted that this is "experimental and might break".
<https://www.openwall.com/lists/musl/2019/03/27/1>.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
toolchain/musl/common.mk

index ae7758e8b55d3a01b69aedda4814b837c0095062..2f07a76c277361e2e2341a58d15538a827cf94e1 100644 (file)
@@ -15,7 +15,7 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=e97681d6f2c44bf5fa9ecdd30607cb63c780062e
 PKG_MIRROR_HASH:=a6655418698735e19fe1c2deffb7335bbda634385c636206dd3cd5c8194a3ce0
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=e97681d6f2c44bf5fa9ecdd30607cb63c780062e
 PKG_MIRROR_HASH:=a6655418698735e19fe1c2deffb7335bbda634385c636206dd3cd5c8194a3ce0
-PKG_SOURCE_URL:=git://git.musl-libc.org/musl
+PKG_SOURCE_URL:=https://git.musl-libc.org/git/musl
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
 LIBC_SO_VERSION:=$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
 
 LIBC_SO_VERSION:=$(PKG_VERSION)