dropbear: Install /etc/config as 600
authorRosen Penev <rosenp@gmail.com>
Wed, 19 Sep 2018 01:32:17 +0000 (18:32 -0700)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 19 Sep 2018 08:41:28 +0000 (09:41 +0100)
/etc/config/dropbear is used by the init script which only runs as root.

Small whitespace change.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/network/services/dropbear/Makefile

index 61136606ad93dd5abbfab516cebf8f1340c19605..460c38dc2afc0452cd475b4ba6aadabf6346bcf7 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=2017.75
-PKG_RELEASE:=7
+PKG_RELEASE:=8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
@@ -61,7 +61,7 @@ endef
 
 define Package/dropbear/conffiles
 /etc/dropbear/dropbear_rsa_host_key
-/etc/config/dropbear 
+/etc/config/dropbear
 endef
 
 define Package/dropbearconvert
@@ -138,7 +138,7 @@ define Package/dropbear/install
        $(LN) ../sbin/dropbear $(1)/usr/bin/dbclient
        $(LN) ../sbin/dropbear $(1)/usr/bin/dropbearkey
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/dropbear.config $(1)/etc/config/dropbear
+       $(INSTALL_CONF) ./files/dropbear.config $(1)/etc/config/dropbear
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/dropbear.init $(1)/etc/init.d/dropbear
        $(INSTALL_DIR) $(1)/usr/lib/opkg/info