tools/quilt: update to 0.65
authorHannu Nyman <hannu.nyman@iki.fi>
Fri, 25 Nov 2016 14:08:31 +0000 (16:08 +0200)
committerJohn Crispin <john@phrozen.org>
Sat, 26 Nov 2016 20:59:40 +0000 (21:59 +0100)
User-visible changes since 0.64 are as follows:

  - Translation fixes
  - Project settings have priority
  - Reject binary files in patches
  - Fix a race condition in diff_file
  - Performance: Optimizations to the setup command
  - Performance: Optimizations to the bash completion script
  - Test suite: Improve the edit test case
  - Test suite: Make the symlink test more robust
  - Test suite: Test backup failure
  - Test suite: Test the header command with hard links
  - diff: Report diff failures
  - edit: Fix a corner case bug
  - mail: Fix the help text
  - push: Fix the synopsis
  - refresh: Do not remove symlinks
  - refresh: Break links to read-only patch files
  - refresh: Always preserve modification time
  - setup: Report failed look-ups in inspect-wrapper
  - quilt.el: Fix quilt-editable when patches are stored in subdirs
  - bash_completion: Handle spaces in file names
  - bash_completion: Update the list of commands
  - bash_completion: Add new command options
  - bash_completion: Fix handling of mail, new, push options
  - guards: Simplify the help text
  - guards: Include the file name also in the "Not found" case
  - guards: Add support for an external filelist in --check mode
  - guards: Report which config file has problem in --check mode
  - guards: Documentation update
  - guards: Clarify a user message

Note to packagers: the Makefile was modified to take configure's
--sysconfdir into account as other projects do. As a result, setting
--prefix=/usr will no longer put the configuration files under /etc.
You now need to explicitly pass --sysconfdir=/etc. If you don't,
configuration files will go under /usr/etc, which is not what you want.
This is somewhat less intuitive, but also more consistent with what
other projects are doing.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
tools/quilt/Makefile
tools/quilt/patches/001-fix_compile.patch

index 939ba691637afe307a1c4628b2b22a8a58865197..1cfa57791be8eb9f6500ffb13b15cf5825b2bfbd 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quilt
-PKG_VERSION:=0.64
+PKG_VERSION:=0.65
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/quilt
-PKG_MD5SUM:=fc0310db5868a0873d602d4332a76d43
+PKG_MD5SUM:=c67ba0228f5b7b8bbe469474661f92d6
 
 include $(INCLUDE_DIR)/host-build.mk
 
index 3ce93f0cf8e945b17e39c1e0af42709f38925d59..c829515f83d56a743f5e5c7489a91c685eccd3dd 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -271,13 +271,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+@@ -272,13 +272,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
        @$(if $(filter $@,$(NON_EXEC_IN)),,chmod +x $@)
  
  configure : configure.ac aclocal.m4