include/package-ipkg.mk: fix typo
authorNicolas Thill <nico@openwrt.org>
Wed, 26 Oct 2011 00:49:07 +0000 (00:49 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 26 Oct 2011 00:49:07 +0000 (00:49 +0000)
Fix a typo that caused packaging of an empty ./lib/upgrade/keep.d
directory when the package supplied conffiles

SVN-Revision: 28595

include/package-ipkg.mk

index 33b9ef83537f98c0bf221df81932169e4cfbe2bc..9eec4f26e948afceb18ddf95c86adbbd6971a49d 100644 (file)
@@ -123,7 +123,7 @@ ifeq ($(DUMP),)
                        for x in $$(KEEP_$(1)); do \
                                [ -f "$$(IDIR_$(1))/$$$$x" ] || keepfiles="$$$${keepfiles:+$$$$keepfiles }$$$$x"; \
                        done; \
-                       [ -z "$keepfiles" ] || { \
+                       [ -z "$$$$keepfiles" ] || { \
                                mkdir -p $$(IDIR_$(1))/lib/upgrade/keep.d; \
                                for x in $$$$keepfiles; do echo $$$$x >> $$(IDIR_$(1))/lib/upgrade/keep.d/$(1); done; \
                        }; \