libelf: fix library packaging
authorJo-Philipp Wich <jo@mein.io>
Fri, 25 Jan 2019 17:57:08 +0000 (18:57 +0100)
committerJo-Philipp Wich <jo@mein.io>
Fri, 25 Jan 2019 17:59:46 +0000 (18:59 +0100)
The library has an usual shared object file name, which caused the
install glob pattern to miss the actual so.

Fixes: #2082
Fixes; 0e70f69a35 ("treewide: revise library packaging")
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/libs/elfutils/Makefile

index a980d35ea87285c790d3d6b24117fd07fae616cd..a67b49ce07433265068c445c18437fd11ce7ca54 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=elfutils
 PKG_VERSION:=0.175
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://sourceware.org/$(PKG_NAME)/ftp/$(PKG_VERSION)
@@ -91,7 +91,7 @@ endef
 
 define Package/libelf/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf*.so.* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libelf{-*.so,*.so.*} $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libasm))