ipq806x: unset filesystem specific build command by default
authorMathias Kresin <dev@kresin.me>
Sun, 14 Jan 2018 20:39:42 +0000 (21:39 +0100)
committerMathias Kresin <dev@kresin.me>
Mon, 15 Jan 2018 20:45:43 +0000 (21:45 +0100)
Initialise the filesystem specific build command. Otherwise it will be
unintended inherit to following images and will cause a wrong image
format.

The issue is around for ages but was only recently triggered due to the
added support for the Openmesh a42.

Fixes: FS#1276
Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ipq806x/image/Makefile

index fd562b91bac3b93aa9b368ad65c428a6c04c528a..bc2e1a43285f66971ce270a51e8fa27836ce9ed9 100644 (file)
@@ -31,6 +31,7 @@ define Device/Default
        KERNEL_LOADADDR = 0x42208000
        SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
        IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
+       IMAGE/sysupgrade.bin/squashfs :=
 endef
 
 define Device/LegacyImage