layerscape: update u-boot to LSDK1712
authorYangbo Lu <yangbo.lu@nxp.com>
Fri, 19 Jan 2018 03:04:25 +0000 (11:04 +0800)
committerJohn Crispin <john@phrozen.org>
Tue, 13 Feb 2018 09:01:51 +0000 (10:01 +0100)
This patch is to update layerscape u-boot to
NXP LSDK1712 release.

Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
package/boot/uboot-layerscape-armv8_32b/Makefile
package/boot/uboot-layerscape/Makefile
package/boot/uboot-layerscape/patches/0001-armv8-ls1043a-add-LEDE-boot-support-in-environment.patch
package/boot/uboot-layerscape/patches/0002-armv8-ls1046ardb-add-LEDE-boot-support-in-environmen.patch

index d1ca8291737f44fde2a9b6912aa967e1ab4bb470..d02b15193d32f180abd89e503c334791dfb25518 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uboot-layerscape-armv8_32b
-PKG_SOURCE_DATE:=2017-10-24
+PKG_SOURCE_DATE:=2018-01-19
 PKG_RELEASE:=1
 
 # Layerscape ARMv8 platforms use 64-bit u-boot to support both 32-bit and 64-bit
@@ -17,8 +17,8 @@ PKG_RELEASE:=1
 # uboot-layerscape's source code.
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/yangbolu1991/u-boot-lede.git
-PKG_SOURCE_VERSION:=43cb4c0fcab237f8daa39c393cc1441b76b99fcf
-PKG_MIRROR_HASH:=ff7d1fcb85dda2be6a9e3785821b5791c7189d2d412b160a9621bb2dcad24dea
+PKG_SOURCE_VERSION:=9fbc70acb44171a3a9be232c17dbed6067a22dfb
+PKG_MIRROR_HASH:=4ad42eb27952fc427e5763295b530b43d29894b9fe9b2cc34b66216ba0cdad70
 
 PKG_MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
 
index c37b335b49a25595c430db764c92ae8bc65798f4..1805c1f0d356d2327e49479ae68ff51b6e9c8b38 100644 (file)
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=uboot-layerscape
-PKG_SOURCE_DATE:=2017-08-24
+PKG_SOURCE_DATE:=2017-12-07
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/qoriq-open-source/u-boot.git
-PKG_SOURCE_VERSION:=fbedf04c1bad675eadbac86febdcf759441a02af
-PKG_MIRROR_HASH:=29922f83ce3e8dde163eafcfd07f3595e2779b7a3e8eb43640f058f58248718d
+PKG_SOURCE_VERSION:=9f7df1b406ff11409021cd2112beedd6b57bb600
+PKG_MIRROR_HASH:=b3756f814b731af2d03b0582ece90b2de564955b778f341fbfc34fa9bd849819
 
 include $(INCLUDE_DIR)/u-boot.mk
 include $(INCLUDE_DIR)/package.mk
index 5973831665f351232bf4bdfc53213d121a54b0a7..b5adca6202fbc1112a375bd1b3dd89885d09f64e 100644 (file)
@@ -1,21 +1,21 @@
-From 74be1b50f96b3ada0a4fc18f0283659739edbadf Mon Sep 17 00:00:00 2001
+From d1b42455f62baefe7fb782d0d7100715b0fdb41f Mon Sep 17 00:00:00 2001
 From: Yangbo Lu <yangbo.lu@nxp.com>
-Date: Fri, 22 Sep 2017 11:00:12 +0800
-Subject: [PATCH 1/3] armv8: ls1043a: add LEDE boot support in environment
+Date: Fri, 19 Jan 2018 10:16:57 +0800
+Subject: [PATCH] armv8: ls1043a: add LEDE boot support in environment
 
 Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 ---
- include/configs/ls1043a_common.h | 20 +++++++++++++++++++-
- 1 file changed, 19 insertions(+), 1 deletion(-)
+ include/configs/ls1043a_common.h |   20 +++++++++++++++++++-
+ 1 files changed, 19 insertions(+), 1 deletions(-)
 
 diff --git a/include/configs/ls1043a_common.h b/include/configs/ls1043a_common.h
-index 0b3fb4e..5c01111 100644
+index c437ce5..48ecff5 100644
 --- a/include/configs/ls1043a_common.h
 +++ b/include/configs/ls1043a_common.h
-@@ -336,7 +336,19 @@
-       "sd_bootcmd=echo Trying load from SD ..;"   \
-               "mmcinfo; mmc read $load_addr "     \
-               "$kernel_addr_sd $kernel_size_sd ;" \
+@@ -341,7 +341,19 @@
+               "env exists secureboot && mmc read $kernelheader_addr_r "               \
+               "$kernelhdr_addr_sd $kernelhdr_size_sd "                \
+               " && esbc_validate ${kernelheader_addr_r};"     \
 -              " bootm $load_addr#$board\0"
 +              " bootm $load_addr#$board\0" \
 +      "lede_setenv=setenv loadaddr 82000000 && " \
@@ -33,7 +33,7 @@ index 0b3fb4e..5c01111 100644
  
  
  #undef CONFIG_BOOTCOMMAND
-@@ -351,6 +363,12 @@
+@@ -356,6 +368,12 @@
                           "env exists secureboot && esbc_halt;"
  #endif
  
@@ -47,5 +47,5 @@ index 0b3fb4e..5c01111 100644
                                        "earlycon=uart8250,mmio,0x21c0500 "    \
                                        MTDPARTS_DEFAULT
 -- 
-2.7.4
+1.7.1
 
index 418f6287fba1254e7b85c45d945896674f794ff7..d7a6e053e51274525140353f2f1b03cd40377ec4 100644 (file)
@@ -1,22 +1,22 @@
-From dc0e8734ea1c679738377d13bdd9bf3fa644e6b3 Mon Sep 17 00:00:00 2001
+From a5293c6d5fdacf84fdd4772d0532aa5478df4d3c Mon Sep 17 00:00:00 2001
 From: Yangbo Lu <yangbo.lu@nxp.com>
-Date: Fri, 22 Sep 2017 11:36:43 +0800
-Subject: [PATCH 2/3] armv8: ls1046ardb: add LEDE boot support in environment
+Date: Fri, 19 Jan 2018 10:18:47 +0800
+Subject: [PATCH] armv8: ls1046ardb: add LEDE boot support in environment
 
 Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 ---
- include/configs/ls1046a_common.h | 15 ++++++++++++++-
- include/configs/ls1046ardb.h     |  6 ++++++
- 2 files changed, 20 insertions(+), 1 deletion(-)
+ include/configs/ls1046a_common.h |   15 ++++++++++++++-
+ include/configs/ls1046ardb.h     |    6 ++++++
+ 2 files changed, 20 insertions(+), 1 deletions(-)
 
 diff --git a/include/configs/ls1046a_common.h b/include/configs/ls1046a_common.h
-index 4fc2f94..53bd41b 100644
+index d163347..d26147b 100644
 --- a/include/configs/ls1046a_common.h
 +++ b/include/configs/ls1046a_common.h
-@@ -276,7 +276,20 @@
-       "sd_bootcmd=echo Trying load from SD ..;"       \
-               "mmcinfo; mmc read $load_addr "         \
-               "$kernel_addr_sd $kernel_size_sd ;"     \
+@@ -281,7 +281,20 @@
+               "env exists secureboot && mmc read $kernelheader_addr_r "               \
+               "$kernelhdr_addr_sd $kernelhdr_size_sd "                \
+               " && esbc_validate ${kernelheader_addr_r};"     \
 -              " bootm $load_addr#$board\0"
 +              " bootm $load_addr#$board\0" \
 +      "lede_setenv=setenv loadaddr 82000000 && " \
@@ -36,10 +36,10 @@ index 4fc2f94..53bd41b 100644
  
  #define CONFIG_BOOTARGS                       "console=ttyS0,115200 root=/dev/ram0 " \
 diff --git a/include/configs/ls1046ardb.h b/include/configs/ls1046ardb.h
-index f8c15a6..c3b50b1 100644
+index 4475ac7..15e7858 100644
 --- a/include/configs/ls1046ardb.h
 +++ b/include/configs/ls1046ardb.h
-@@ -251,6 +251,12 @@
+@@ -253,6 +253,12 @@
                           "env exists secureboot && esbc_halt;"
  #endif
  
@@ -53,5 +53,5 @@ index f8c15a6..c3b50b1 100644
                        "15m(u-boot),48m(kernel.itb);" \
                        "7e800000.flash:16m(nand_uboot)," \
 -- 
-2.7.4
+1.7.1