kmod-sched: add act_police
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Thu, 9 Apr 2020 08:19:13 +0000 (09:19 +0100)
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Fri, 10 Apr 2020 11:26:31 +0000 (12:26 +0100)
"Whoop whoop, sound of da police"

Add an ingress capable traffic policer module configurable with tc.

From the man page:

The police action allows to limit bandwidth of traffic matched by the
filter it is attached to. Basically there are two different algorithms
available to measure the packet rate: The first one uses an internal
dual token bucket and is configured using the rate, burst, mtu,
peakrate, overhead and linklayer parameters. The second one uses an
in-kernel sampling mechanism. It can be fine-tuned using the estimator
filter parameter.

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
package/kernel/linux/modules/netsupport.mk

index 6dade49bade8d2f687cf4e5b7b685f327aeb1172..75222889c0d0427528c02b7ce4afc516476aacf2 100644 (file)
@@ -867,6 +867,16 @@ define KernelPackage/sched-ctinfo
 endef
 $(eval $(call KernelPackage,sched-ctinfo))
 
+define KernelPackage/sched-police
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Traffic shaper police support
+  DEPENDS:=+kmod-sched-core
+  KCONFIG:=CONFIG_NET_ACT_POLICE
+  FILES:=$(LINUX_DIR)/net/sched/act_police.ko
+  AUTOLOAD:=$(call AutoLoad,71, act_police)
+endef
+$(eval $(call KernelPackage,sched-police))
+
 define KernelPackage/sched-ipset
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Traffic shaper ipset support