mpc85xx: remove USB support from kernel
authorDavid Bauer <mail@david-bauer.net>
Mon, 8 Apr 2019 18:09:34 +0000 (20:09 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 13 Apr 2019 13:09:09 +0000 (15:09 +0200)
This removes USB support from the compiled kernel. Because of this, the
kernel is just small enough for the TP-Link WDR4900 to boot the
resulting kernel.

This is necessary to support the WDR4900 in the upcoming 19.xx release.
In the long run, this should be fixed with a second stage bootloader, as
the vendor bootloader only loads the first 2684k bytes.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/mpc85xx/Makefile
target/linux/mpc85xx/config-4.14
target/linux/mpc85xx/config-4.19

index 370ef81f15c1562e74f2f8a2ae15fd5fc330434d..02fdc2f53da6030c983062cf5933311d4adc0cba 100644 (file)
@@ -22,6 +22,6 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio swconfig kmod-ath9k wpad-basic
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2-fsl
 
 $(eval $(call BuildTarget))
index f057e5c910b118cbce2c2cf2e68acee6a6d37c16..f2337210d4f90dee075d711b2a8d088ec6b9a515 100644 (file)
@@ -354,13 +354,6 @@ CONFIG_UCC=y
 CONFIG_UCC_FAST=y
 CONFIG_UCC_GETH=y
 # CONFIG_UGETH_TX_ON_DEMAND is not set
-CONFIG_USB=y
-CONFIG_USB_COMMON=y
-CONFIG_USB_EHCI_FSL=y
-CONFIG_USB_EHCI_HCD=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
-CONFIG_USB_EHCI_HCD_PPC_OF=y
-CONFIG_USB_FHCI_HCD=y
 CONFIG_USB_SUPPORT=y
 CONFIG_VDSO32=y
 # CONFIG_VIRT_CPU_ACCOUNTING_NATIVE is not set
index c92edcfa376898ffeef08695967a57ea2b87ee19..df4d741c27e500d9fa44be01b536e9febc90306b 100644 (file)
@@ -315,13 +315,6 @@ CONFIG_UCC=y
 CONFIG_UCC_FAST=y
 CONFIG_UCC_GETH=y
 # CONFIG_UGETH_TX_ON_DEMAND is not set
-CONFIG_USB=y
-CONFIG_USB_COMMON=y
-CONFIG_USB_EHCI_FSL=y
-CONFIG_USB_EHCI_HCD=y
-# CONFIG_USB_EHCI_HCD_PLATFORM is not set
-CONFIG_USB_EHCI_HCD_PPC_OF=y
-CONFIG_USB_FHCI_HCD=y
 CONFIG_USB_SUPPORT=y
 CONFIG_VDSO32=y
 # CONFIG_VIRT_CPU_ACCOUNTING_NATIVE is not set