kernel: bump 4.14 to 4.14.97
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Thu, 31 Jan 2019 15:52:41 +0000 (16:52 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 1 Feb 2019 10:41:00 +0000 (11:41 +0100)
Refreshed all patches.

Adapted patches:
- 012-kbuild-add-macro-for-controlling-warnings-to-linux-c.patch

Compile-tested on: ar71xx, cns3xxx, imx6, x86_64
Runtime-tested on: ar71xx, cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
12 files changed:
include/kernel-version.mk
target/linux/ar71xx/patches-4.14/950-add-boardinfo-platform-data.patch
target/linux/brcm2708/patches-4.14/950-0292-net-mdiobus-add-unlocked-accessors.patch
target/linux/generic/backport-4.14/012-kbuild-add-macro-for-controlling-warnings-to-linux-c.patch
target/linux/generic/backport-4.14/420-enable-CONFIG_MMC_SDHCI_IO_ACCESSORS.patch
target/linux/generic/hack-4.14/902-debloat_proc.patch
target/linux/generic/pending-4.14/644-net-pppoe-support-hardware-flow-table-offload.patch
target/linux/generic/pending-4.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/layerscape/patches-4.14/202-core-linux-support-layerscape.patch
target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
target/linux/mediatek/patches-4.14/0190-usb-xhci-mtk-supports-remote-wakeup-for-mt2712-with-.patch
target/linux/ramips/patches-4.14/0046-mmc-MIPS-ralink-add-sdhci-for-mt7620a-SoC.patch

index e52b791d8b2ad1a05e192aa4696fa6b9a529bec8..5972c315fddb0f6263efcdf8f25edb953295bc2f 100644 (file)
@@ -4,12 +4,12 @@ LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .133
 LINUX_VERSION-4.9 = .154
-LINUX_VERSION-4.14 = .96
+LINUX_VERSION-4.14 = .97
 LINUX_VERSION-4.19 = .18
 
 LINUX_KERNEL_HASH-3.18.133 = 3ec7f47365a8a050e629a5016e90e38a800e840c844901c979e9e796f8dc6711
 LINUX_KERNEL_HASH-4.9.154 = 5b314f1ac16f78e10acea0053f0c758e696b28f80272064e0a06bc69dc9d5696
-LINUX_KERNEL_HASH-4.14.96 = 110daeae1a416b7e0ec8dce5e86d67552deeb4567f696c3869389be239f0ecb5
+LINUX_KERNEL_HASH-4.14.97 = 8dd2c831ddabfc6241ddca946e600376785fd6f225a24655bc36a0c6b4e945f4
 LINUX_KERNEL_HASH-4.19.18 = 5ffdc068f9bf768b7cd5a8a2271d1370c2326e967848b13e21dfdbb1ef0ff3f1
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
index edeac838d90f88a2267036428b441c19e106f361..6b0d30002337756e80bd11f1b40cd6efcc0c0c65 100644 (file)
@@ -26,7 +26,7 @@
  #endif /* __MDIO_BOARD_INFO_H */
 --- a/drivers/net/phy/mdio_bus.c
 +++ b/drivers/net/phy/mdio_bus.c
-@@ -455,6 +455,17 @@ void mdiobus_free(struct mii_bus *bus)
+@@ -456,6 +456,17 @@ void mdiobus_free(struct mii_bus *bus)
  }
  EXPORT_SYMBOL(mdiobus_free);
  
@@ -44,7 +44,7 @@
  /**
   * mdiobus_scan - scan a bus for MDIO devices.
   * @bus: mii_bus to scan
-@@ -470,6 +481,7 @@ EXPORT_SYMBOL(mdiobus_free);
+@@ -471,6 +482,7 @@ EXPORT_SYMBOL(mdiobus_free);
  struct phy_device *mdiobus_scan(struct mii_bus *bus, int addr)
  {
        struct phy_device *phydev;
@@ -52,7 +52,7 @@
        int err;
  
        phydev = get_phy_device(bus, addr, false);
-@@ -482,6 +494,12 @@ struct phy_device *mdiobus_scan(struct m
+@@ -483,6 +495,12 @@ struct phy_device *mdiobus_scan(struct m
         */
        of_mdiobus_link_mdiodev(bus, &phydev->mdio);
  
index 5aec47e6042484266e684042996136f1cf020385..3bf86f612e86a2a2f6b3fed4e728261c7d3e9b6c 100644 (file)
@@ -19,7 +19,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/phy/mdio_bus.c
 +++ b/drivers/net/phy/mdio_bus.c
-@@ -493,6 +493,55 @@ struct phy_device *mdiobus_scan(struct m
+@@ -494,6 +494,55 @@ struct phy_device *mdiobus_scan(struct m
  EXPORT_SYMBOL(mdiobus_scan);
  
  /**
@@ -75,7 +75,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
   * mdiobus_read_nested - Nested version of the mdiobus_read function
   * @bus: the mii_bus struct
   * @addr: the phy address
-@@ -512,11 +561,9 @@ int mdiobus_read_nested(struct mii_bus *
+@@ -513,11 +562,9 @@ int mdiobus_read_nested(struct mii_bus *
        BUG_ON(in_interrupt());
  
        mutex_lock_nested(&bus->mdio_lock, MDIO_MUTEX_NESTED);
@@ -88,7 +88,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return retval;
  }
  EXPORT_SYMBOL(mdiobus_read_nested);
-@@ -538,11 +585,9 @@ int mdiobus_read(struct mii_bus *bus, in
+@@ -539,11 +586,9 @@ int mdiobus_read(struct mii_bus *bus, in
        BUG_ON(in_interrupt());
  
        mutex_lock(&bus->mdio_lock);
@@ -101,7 +101,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return retval;
  }
  EXPORT_SYMBOL(mdiobus_read);
-@@ -568,11 +613,9 @@ int mdiobus_write_nested(struct mii_bus
+@@ -569,11 +614,9 @@ int mdiobus_write_nested(struct mii_bus
        BUG_ON(in_interrupt());
  
        mutex_lock_nested(&bus->mdio_lock, MDIO_MUTEX_NESTED);
@@ -114,7 +114,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        return err;
  }
  EXPORT_SYMBOL(mdiobus_write_nested);
-@@ -595,11 +638,9 @@ int mdiobus_write(struct mii_bus *bus, i
+@@ -596,11 +639,9 @@ int mdiobus_write(struct mii_bus *bus, i
        BUG_ON(in_interrupt());
  
        mutex_lock(&bus->mdio_lock);
index 7617c2e5f554af27e720ddf134d03dadbde4aaf0..8d91266e244d1edd23fa558701bea10275752027 100644 (file)
@@ -84,10 +84,11 @@ Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
 
 --- a/include/linux/compiler-gcc.h
 +++ b/include/linux/compiler-gcc.h
-@@ -358,3 +358,28 @@
-  * code
-  */
- #define uninitialized_var(x) x = x
+@@ -362,3 +362,30 @@
+ #if GCC_VERSION >= 50100
+ #define COMPILER_HAS_GENERIC_BUILTIN_OVERFLOW 1
+ #endif
++
 +
 +/*
 + * Turn individual warnings and errors on and off locally, depending
@@ -113,6 +114,7 @@ Signed-off-by: Masahiro Yamada <yamada.masahiro@socionext.com>
 +#else
 +#define __diag_GCC_8(s)
 +#endif
++
 --- a/include/linux/compiler_types.h
 +++ b/include/linux/compiler_types.h
 @@ -283,4 +283,22 @@ struct ftrace_likely_data {
index 744cf4cff26bbaf77b427bf178c4de1a89dc63be..eabfc64378e4e7778a2ff4aa28f6d859346bfd31 100644 (file)
@@ -13,11 +13,11 @@ Acked-by: Adrian Hunter <adrian.hunter@intel.com>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -429,6 +429,7 @@ config MMC_SDHCI_MSM
-       tristate "Qualcomm SDHCI Controller Support"
-       depends on ARCH_QCOM || (ARM && COMPILE_TEST)
+@@ -310,6 +310,7 @@ config MMC_SDHCI_BCM_KONA
+       tristate "SDHCI support on Broadcom KONA platform"
+       depends on ARCH_BCM_MOBILE
        depends on MMC_SDHCI_PLTFM
 +      select MMC_SDHCI_IO_ACCESSORS
        help
-         This selects the Secure Digital Host Controller Interface (SDHCI)
-         support present in Qualcomm SOCs. The controller supports
+         This selects the Broadcom Kona Secure Digital Host Controller
+         Interface(SDHCI) support.
index 3475a570146df947cd20b321c7153ca8981fb83d..94553805685af2491afdb39dadd0280c5a201d1b 100644 (file)
@@ -338,7 +338,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2731,10 +2731,12 @@ static const struct file_operations fib_
+@@ -2740,10 +2740,12 @@ static const struct file_operations fib_
  
  int __net_init fib_proc_init(struct net *net)
  {
@@ -353,7 +353,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                         &fib_triestat_fops))
                goto out2;
  
-@@ -2744,17 +2746,21 @@ int __net_init fib_proc_init(struct net
+@@ -2753,17 +2755,21 @@ int __net_init fib_proc_init(struct net
        return 0;
  
  out3:
index edba04ccf6f68e66ec0ad51bd90ff51f4e0e2a53..ae8c4ca92130b9a522ef3697e1204265c44f4b4e 100644 (file)
@@ -73,7 +73,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #include <linux/nsproxy.h>
  #include <net/net_namespace.h>
  #include <net/netns/generic.h>
-@@ -977,8 +982,36 @@ static int pppoe_xmit(struct ppp_channel
+@@ -978,8 +983,36 @@ static int pppoe_xmit(struct ppp_channel
        return __pppoe_xmit(sk, skb);
  }
  
index 36aaccbdb3e1dcb761eeb9ab82f7747cbc480f48..03bb755619087765bc50dddc3cc03b7b49298c85 100644 (file)
@@ -66,7 +66,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static void rt_fibinfo_free(struct rtable __rcu **rtp)
 --- a/net/ipv4/fib_trie.c
 +++ b/net/ipv4/fib_trie.c
-@@ -2460,6 +2460,7 @@ static const char *const rtn_type_names[
+@@ -2469,6 +2469,7 @@ static const char *const rtn_type_names[
        [RTN_THROW] = "THROW",
        [RTN_NAT] = "NAT",
        [RTN_XRESOLVE] = "XRESOLVE",
index 15ccde48c66bea5bb41d5dd35a7e74ddaf7ac240..bef6de235f722bd0e96c29509874d1eb582b08b7 100644 (file)
@@ -241,7 +241,7 @@ Signed-off-by: Biwen Li <biwen.li@nxp.com>
  void  __kfree_skb(struct sk_buff *skb);
  extern struct kmem_cache *skbuff_head_cache;
  
-@@ -3293,6 +3294,7 @@ static inline void skb_free_datagram_loc
+@@ -3294,6 +3295,7 @@ static inline void skb_free_datagram_loc
  }
  int skb_kill_datagram(struct sock *sk, struct sk_buff *skb, unsigned int flags);
  int skb_copy_bits(const struct sk_buff *skb, int offset, void *to, int len);
index 5fd8350b6badda01cf8821ca71d801af5b93d525..45ed8efa9fdb4b024fe5a22705a8b2bae4ba2310 100644 (file)
@@ -432,7 +432,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                reg &= ~DWC3_DCTL_INITU2ENA;
 --- a/drivers/usb/dwc3/gadget.c
 +++ b/drivers/usb/dwc3/gadget.c
-@@ -3203,6 +3203,7 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3205,6 +3205,7 @@ int dwc3_gadget_init(struct dwc3 *dwc)
  {
        int ret;
        int irq;
@@ -440,7 +440,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
  
        irq = dwc3_gadget_get_irq(dwc);
        if (irq < 0) {
-@@ -3279,6 +3280,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
+@@ -3281,6 +3282,12 @@ int dwc3_gadget_init(struct dwc3 *dwc)
                goto err4;
        }
  
@@ -1253,7 +1253,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
                while (ep_ring->dequeue != td->last_trb)
 --- a/drivers/usb/host/xhci.c
 +++ b/drivers/usb/host/xhci.c
-@@ -1599,13 +1599,38 @@ static int xhci_urb_dequeue(struct usb_h
+@@ -1597,13 +1597,38 @@ static int xhci_urb_dequeue(struct usb_h
                        ret = -ENOMEM;
                        goto done;
                }
@@ -1298,7 +1298,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
        }
  done:
        spin_unlock_irqrestore(&xhci->lock, flags);
-@@ -4990,7 +5015,7 @@ int xhci_gen_setup(struct usb_hcd *hcd,
+@@ -4988,7 +5013,7 @@ int xhci_gen_setup(struct usb_hcd *hcd,
                return retval;
        xhci_dbg(xhci, "Called HCD init\n");
  
index 2ae76eda17ddbf93c403fabca64ff0695d71cd36..c49efcbd382dbdd0a24d8753b728e8ad3b43e588 100644 (file)
@@ -229,7 +229,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
  
        mtk->num_phys = of_count_phandle_with_args(node,
                        "phys", "#phy-cells");
-@@ -780,7 +723,7 @@ static int __maybe_unused xhci_mtk_suspe
+@@ -782,7 +725,7 @@ static int __maybe_unused xhci_mtk_suspe
        xhci_mtk_host_disable(mtk);
        xhci_mtk_phy_power_off(mtk);
        xhci_mtk_clks_disable(mtk);
@@ -238,7 +238,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
        return 0;
  }
  
-@@ -790,7 +733,7 @@ static int __maybe_unused xhci_mtk_resum
+@@ -792,7 +735,7 @@ static int __maybe_unused xhci_mtk_resum
        struct usb_hcd *hcd = mtk->hcd;
        struct xhci_hcd *xhci = hcd_to_xhci(hcd);
  
index 4c4147ef52fcbc8fc0194b11d9e85db16c16b002..0535811ea3127d10fc5f91507a4652b39509c45b 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/drivers/mmc/host/Kconfig
 +++ b/drivers/mmc/host/Kconfig
-@@ -900,3 +900,5 @@ config MMC_SDHCI_XENON
+@@ -901,3 +901,5 @@ config MMC_SDHCI_XENON
          This selects Marvell Xenon eMMC/SD/SDIO SDHCI.
          If you have a controller with this interface, say Y or M here.
          If unsure, say N.