ramips: RE350: add rootfs offset to header
authorAlex Maclean <monkeh@monkeh.net>
Wed, 20 Jun 2018 13:56:21 +0000 (14:56 +0100)
committerJohn Crispin <john@phrozen.org>
Tue, 26 Jun 2018 05:04:43 +0000 (07:04 +0200)
Have mktplinkfw fill in the rootfs offset so the firmware splitter can
find it without aligning to erase blocks.

Signed-off-by: Alex Maclean <monkeh@monkeh.net>
target/linux/ramips/image/mt7621.mk

index e9e2d3ecef0c5be28232266c296f7946c401617f..778f3d6bf84a51c737209208ac6bb754576a97ac 100644 (file)
@@ -256,7 +256,7 @@ define Device/re350-v1
   TPLINK_HWREV := 0
   TPLINK_HEADER_VERSION := 1
   IMAGE_SIZE := 6016k
-  KERNEL := $(KERNEL_DTB) | tplink-v1-header -e
+  KERNEL := $(KERNEL_DTB) | tplink-v1-header -e -O
   IMAGES := sysupgrade.bin factory.bin
   IMAGE/sysupgrade.bin := append-rootfs | tplink-safeloader sysupgrade | append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory