at91: fix legacy build
authorHauke Mehrtens <hauke@hauke-m.de>
Mon, 16 Oct 2017 19:36:17 +0000 (21:36 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 16 Oct 2017 21:05:54 +0000 (23:05 +0200)
The build system took the DTB_SIZE definition from Default and not from
production-dtb under some conditions. Move the size definitions to
Default now as it is only used in production-dtb anyway.

Thanks Mathias Kresin for helping me with this.

Fixes: c2f052acaeb ("at91: convert boards to generic build target")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/at91/image/Makefile

index fedefe428786ba687d5e7b64519db6b8bf5d51cb..12607073e4a75659180e156133c30bec558dd272 100644 (file)
@@ -24,7 +24,7 @@ define Device/Default
   KERNEL_NAME := zImage
   KERNEL_SIZE := 4096k
   KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
-  DTB_SIZE :=
+  DTB_SIZE := 128k
 endef
 
 define Device/dtb
@@ -66,7 +66,6 @@ endef
 define Device/production-dtb
   $(Device/production)
   $(Device/dtb)
-  DTB_SIZE := 128k
   IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
          | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef