ar71xx: add support for TP-Link Archer C60 v2
authorHenryk Heisig <hyniu@o2.pl>
Mon, 15 Jan 2018 05:44:14 +0000 (06:44 +0100)
committerPiotr Dymacz <pepe2k@gmail.com>
Fri, 6 Apr 2018 22:09:05 +0000 (00:09 +0200)
TP-Link Archer C60 v2 is a dual-band AC1350 router, based on
Qualcomm/Atheros QCA9561 + QCA9886.

Specification:

- 775/650/258 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR2)
- 8 MB of FLASH (SPI NOR)
- 3T3R 2.4 GHz
- 2T2R 5 GHz
- 5x 10/100 Mbps Ethernet
- 7x LED, 2x button
- UART header on PCB

Flash instruction (web):

Download lede-ar71xx-generic-archer-c60-v2-squashfs-factory.bin and use
OEM System Tools - Firmware Upgrade site.

Flash instruction (recovery):

1. Set PC to fixed IP address 192.168.0.66
2. Download lede-ar71xx-generic-archer-c60-v2-squashfs-factory.bin and
   rename it to tp_recovery.bin
3. Start a tftp server with the file tp_recovery.bin in its root
   directory
4. Turn off the router
5. Press and hold reset button
6. Turn on router with the reset button pressed and wait ~15 seconds
7. Release the reset button and after a short time the firmware should
   be transferred from the tftp server
8. Wait ~30 second to complete recovery

Flash instruction (under U-Boot, using UART):

tftp 0x81000000 lede-ar71xx-...-sysupgrade.bin
erase 0x9f030000 +$filesize
cp.b $fileaddr 0x9f030000 $filesize
reset

Signed-off-by: Henryk Heisig <hyniu@o2.pl>
15 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ar71xx/base-files/etc/hotplug.d/ieee80211/10_fix_wifi_mac
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.9
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c60-v1.c
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/generic/config-default
target/linux/ar71xx/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 58e2c9743ca8c9721f65e629aa055c526bf16272..cf24e465a3ae03b9418d2fad603593da98a43410 100755 (executable)
@@ -128,7 +128,8 @@ archer-c7)
        ;;
 archer-c58-v1|\
 archer-c59-v1|\
-archer-c60-v1)
+archer-c60-v1|\
+archer-c60-v2)
        ucidef_set_led_switch "lan" "LAN" "$board:green:lan" "switch0" "0x1E"
        ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth0"
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan2g" "phy1tpt"
index ffdc90fbfcb457def2d32799ae2ba14836169e02..dfe97e8133cc801c00045ad36646dcf26c40236c 100755 (executable)
@@ -248,7 +248,8 @@ ar71xx_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:1" "2:lan:4" "3:lan:3" "4:lan:2"
                ;;
-       archer-c60-v1)
+       archer-c60-v1|\
+       archer-c60-v2)
                ucidef_set_interfaces_lan_wan "eth1.1" "eth0"
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:1" "2:lan:2" "3:lan:3" "4:lan:4"
index bd0926c213fcc1087b66dc4623933b9009dc0e0a..797c30f8a5f04ece86796d9df68da6127de1b0aa 100644 (file)
@@ -64,6 +64,7 @@ get_status_led() {
        archer-c58-v1|\
        archer-c59-v1|\
        archer-c60-v1|\
+       archer-c60-v2|\
        archer-c7-v4|\
        fritz300e|\
        gl-usb150|\
index c93ce2a61477e6770172308e2269b10c2a5bdd44..5d01701aa89a9e0fb387d10c9c6e72e8be0f1129 100644 (file)
@@ -163,6 +163,7 @@ case "$FIRMWARE" in
        archer-c58-v1|\
        archer-c59-v1|\
        archer-c60-v1|\
+       archer-c60-v2|\
        cf-e355ac-v2|\
        cf-e375ac)
                ath10kcal_extract "art" 20480 12064
index 0530d595a757618d93abe5c7c08492f60f1de4f5..a763938ecda878b767954e8dcb4b1d5807b26160 100644 (file)
@@ -14,7 +14,8 @@ board=$(board_name)
 case "$board" in
        archer-c58-v1|\
        archer-c59-v1|\
-       archer-c60-v1)
+       archer-c60-v1|\
+       archer-c60-v2)
                echo $(macaddr_add $(mtd_get_mac_binary mac 8)  $(($PHYNBR - 1)) ) > /sys${DEVPATH}/macaddress
                ;;
        *)
index b711150ee9b0c3ae14949c1613acc59d1a570343..7249cb61513dfa5ccf97275cde2f00d639d8d937 100755 (executable)
@@ -485,6 +485,9 @@ ar71xx_board_detect() {
        *"Archer C60 v1")
                name="archer-c60-v1"
                ;;
+       *"Archer C60 v2")
+               name="archer-c60-v2"
+               ;;
        *"Archer C7")
                name="archer-c7"
                ;;
index fe927ea55092e44f66d512d50365106c87e72a4e..633a7e8e56731c8ae9f4fecb44cc296e1fcdd8b7 100755 (executable)
@@ -202,6 +202,7 @@ platform_check_image() {
        archer-c58-v1|\
        archer-c59-v1|\
        archer-c60-v1|\
+       archer-c60-v2|\
        archer-c7-v4|\
        bullet-m|\
        c-55|\
index e78b16cd19360a25180958a9f4a99ba2eb60cfe8..5cea1b7bdee17106da4b872d9610f48ce0aafa2a 100644 (file)
@@ -53,6 +53,7 @@ CONFIG_ATH79=y
 # CONFIG_ATH79_MACH_ARCHER_C58_V1 is not set
 # CONFIG_ATH79_MACH_ARCHER_C59_V1 is not set
 # CONFIG_ATH79_MACH_ARCHER_C60_V1 is not set
+# CONFIG_ATH79_MACH_ARCHER_C60_V2 is not set
 # CONFIG_ATH79_MACH_ARCHER_C7 is not set
 # CONFIG_ATH79_MACH_ARDUINO_YUN is not set
 # CONFIG_ATH79_MACH_AW_NR580 is not set
index 965d876e087ca4db3f1dbb7aea85d6e59028e313..4a032f6021670c24dd4281cf0ccff162c22c4a37 100644 (file)
@@ -1529,6 +1529,16 @@ config ATH79_MACH_ARCHER_C60_V1
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_ARCHER_C60_V2
+       bool "TP-LINK Archer C60 v2 support"
+       select SOC_QCA956X
+       select ATH79_DEV_AP9X_PCI if PCI
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_ARCHER_C7
        bool "TP-LINK Archer C5/C7/TL-WDR4900 v2 board support"
        select SOC_QCA955X
index d549dd39b7cfdf981ea0af8d8f36274e57d7dd99..e606e2c3df6098665bf694cf67baace3f71d2bd1 100644 (file)
@@ -63,6 +63,7 @@ obj-$(CONFIG_ATH79_MACH_ARCHER_C25_V1)                += mach-archer-c25-v1.o
 obj-$(CONFIG_ATH79_MACH_ARCHER_C58_V1)         += mach-archer-c59-v1.o
 obj-$(CONFIG_ATH79_MACH_ARCHER_C59_V1)         += mach-archer-c59-v1.o
 obj-$(CONFIG_ATH79_MACH_ARCHER_C60_V1)         += mach-archer-c60-v1.o
+obj-$(CONFIG_ATH79_MACH_ARCHER_C60_V2)         += mach-archer-c60-v1.o
 obj-$(CONFIG_ATH79_MACH_ARCHER_C7)             += mach-archer-c7.o
 obj-$(CONFIG_ATH79_MACH_ARCHER_C7)             += mach-archer-c7-v4.o
 obj-$(CONFIG_ATH79_MACH_ARDUINO_YUN)           += mach-arduino-yun.o
index 4d83fa737b9650935b4f7f985d58f471c38cd9da..88f4f081a34db9b289d393d9c7ad4693ddb9b01d 100644 (file)
@@ -1,7 +1,7 @@
 /*
  *  TP-Link Archer C60 v1 board support
  *
- *  Copyright (C) 2016 Henryk Heisig <hyniu@o2.pl>
+ *  Copyright (C) 2017 Henryk Heisig <hyniu@o2.pl>
  *
  *  This program is free software; you can redistribute it and/or modify it
  *  under the terms of the GNU General Public License version 2 as published
@@ -83,6 +83,44 @@ static struct gpio_led archer_c60_v1_leds_gpio[] __initdata = {
        },
 };
 
+static struct gpio_led archer_c60_v2_leds_gpio[] __initdata = {
+       {
+               .name           = "archer-c60-v2:green:power",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_POWER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v2:green:wlan2g",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WLAN2,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v2:green:wlan5g",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WLAN5,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v2:green:lan",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_LAN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v2:green:wan",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WAN_GREEN,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v2:amber:wan",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WAN_AMBER,
+               .active_low     = 1,
+       },
+       {
+               .name           = "archer-c60-v2:green:wps",
+               .gpio           = ARCHER_C60_V1_GPIO_LED_WPS,
+               .active_low     = 1,
+       },
+};
+
 static struct gpio_keys_button archer_c60_v1_gpio_keys[] __initdata = {
        {
                .desc                   = "Reset button",
@@ -143,3 +181,45 @@ static void __init archer_c60_v1_setup(void)
 
 MIPS_MACHINE(ATH79_MACH_ARCHER_C60_V1, "ARCHER-C60-V1",
        "TP-LINK Archer C60 v1", archer_c60_v1_setup);
+
+static void __init archer_c60_v2_setup(void)
+{
+       u8 *mac = (u8 *) KSEG1ADDR(0x1f01fb08);
+       u8 *art = (u8 *) KSEG1ADDR(0x1f7f0000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(archer_c60_v2_leds_gpio),
+                               archer_c60_v2_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, ARCHER_C60_V1_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(archer_c60_v1_gpio_keys),
+                                       archer_c60_v1_gpio_keys);
+
+       ath79_register_mdio(0, 0x0);
+       ath79_register_mdio(1, 0x0);
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac, 1);
+
+       /* WAN port */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_MII;
+       ath79_eth0_data.speed = SPEED_100;
+       ath79_eth0_data.duplex = DUPLEX_FULL;
+       ath79_eth0_data.phy_mask = BIT(4);
+       ath79_register_eth(0);
+
+       /* LAN ports */
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_GMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_switch_data.phy_poll_mask |= BIT(4);
+       ath79_switch_data.phy4_mii_en = 1;
+       ath79_register_eth(1);
+
+       ath79_register_wmac(art + ARCHER_C60_V1_WMAC_CALDATA_OFFSET, mac);
+       ap91_pci_init(art + ARCHER_C60_V1_PCI_CALDATA_OFFSET, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_ARCHER_C60_V2, "ARCHER-C60-V2",
+       "TP-LINK Archer C60 v2", archer_c60_v2_setup);
index 6007b512aa783cac8f1384550f51f520d51db0f4..b61ed7abcdfa18451ef71170416443fd364c9e30 100644 (file)
@@ -48,6 +48,7 @@ enum ath79_mach_type {
        ATH79_MACH_ARCHER_C58_V1,               /* TP-LINK Archer C58 V1 board */
        ATH79_MACH_ARCHER_C59_V1,               /* TP-LINK Archer C59 V1 board */
        ATH79_MACH_ARCHER_C60_V1,               /* TP-LINK Archer C60 V1 board */
+       ATH79_MACH_ARCHER_C60_V2,               /* TP-LINK Archer C60 V2 board */
        ATH79_MACH_ARCHER_C7,                   /* TP-LINK Archer C7 board */
        ATH79_MACH_ARCHER_C7_V2,                /* TP-LINK Archer C7 V2 board */
        ATH79_MACH_ARCHER_C7_V4,                /* TP-LINK Archer C7 V4 board */
index 088824d31ded390694a60a5fa494ee4d4ef144d0..6475d2281a7e1fd4d4670c052b615e92c43a2598 100644 (file)
@@ -31,6 +31,7 @@ CONFIG_ATH79_MACH_ARCHER_C25_V1=y
 CONFIG_ATH79_MACH_ARCHER_C58_V1=y
 CONFIG_ATH79_MACH_ARCHER_C59_V1=y
 CONFIG_ATH79_MACH_ARCHER_C60_V1=y
+CONFIG_ATH79_MACH_ARCHER_C60_V2=y
 CONFIG_ATH79_MACH_ARCHER_C7=y
 CONFIG_ATH79_MACH_ARDUINO_YUN=y
 CONFIG_ATH79_MACH_AW_NR580=y
index 48eed6b15ba072a7ce49079e8e54be925463ceff..9054f1c7da44c75d0862b9b578ffef9635aba4bb 100644 (file)
@@ -62,6 +62,18 @@ define Device/archer-c60-v1
 endef
 TARGET_DEVICES += archer-c60-v1
 
+define Device/archer-c60-v2
+  $(Device/archer-c60-v1)
+  DEVICE_TITLE := TP-LINK Archer C60 v2
+  BOARDNAME := ARCHER-C60-V2
+  TPLINK_BOARD_ID := ARCHER-C60-V2
+  DEVICE_PROFILE := ARCHERC60V2
+  IMAGE_SIZE := 7808k
+  MTDPARTS := spi0.0:192k(u-boot)ro,7808k(firmware),128k(tplink)ro,64k(art)ro
+  SUPPORTED_DEVICES := archer-c60-v2
+endef
+TARGET_DEVICES += archer-c60-v2
+
 define Device/archer-c5-v1
   $(Device/tplink-16mlzma)
   DEVICE_TITLE := TP-LINK Archer C5 v1
index eb99241136b2f1c82d0e8ae43f7f66f768c18098..2e83b71c44e67fbcf184ca78129cbedfe92923d8 100644 (file)
@@ -451,6 +451,43 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "file-system",
        },
 
+       /** Firmware layout for the C60v2 */
+       {
+               .id     = "ARCHER-C60-V2",
+               .vendor = "",
+               .support_list =
+                       "SupportList:\r\n"
+                       "{product_name:Archer C60,product_ver:2.0.0,special_id:42520000}\r\n"
+                       "{product_name:Archer C60,product_ver:2.0.0,special_id:45550000}\r\n"
+                       "{product_name:Archer C60,product_ver:2.0.0,special_id:55530000}\r\n",
+               .support_trail = '\x00',
+               .soft_ver = "soft_ver:2.0.0\n",
+
+               .partitions = {
+                       {"factory-boot", 0x00000, 0x1fb00},
+                       {"default-mac", 0x1fb00, 0x00200},
+                       {"pin", 0x1fd00, 0x00100},
+                       {"product-info", 0x1fe00, 0x00100},
+                       {"device-id", 0x1ff00, 0x00100},
+                       {"fs-uboot", 0x20000, 0x10000},
+                       {"os-image", 0x30000, 0x180000},
+                       {"file-system", 0x1b0000, 0x620000},
+                       {"soft-version", 0x7d9500, 0x00100},
+                       {"support-list", 0x7d9600, 0x00100},
+                       {"extra-para", 0x7d9700, 0x00100},
+                       {"profile", 0x7d9800, 0x03000},
+                       {"default-config", 0x7dc800, 0x03000},
+                       {"partition-table", 0x7df800, 0x00800},
+                       {"user-config", 0x7e0000, 0x0c000},
+                       {"certificate", 0x7ec000, 0x04000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system",
+       },
+
        /** Firmware layout for the C5 */
        {
                .id = "ARCHER-C5-V2",
@@ -1343,6 +1380,7 @@ static void build_image(const char *output,
 
        /* Some devices need the extra-para partition to accept the firmware */
        if (strcasecmp(info->id, "ARCHER-C25-V1") == 0 ||
+           strcasecmp(info->id, "ARCHER-C60-V2") == 0 ||
            strcasecmp(info->id, "TLWR1043NV5") == 0) {
                const char mdat[11] = {0x00, 0x00, 0x00, 0x02, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00, 0x00};
                parts[5] = put_data("extra-para", mdat, 11);