ath79: add support for OCEDO Ursus
authorMarkus Scheck <markus.scheck1@gmail.com>
Thu, 21 Mar 2019 15:43:27 +0000 (16:43 +0100)
committerPetr Štetiar <ynezz@true.cz>
Mon, 8 Apr 2019 16:37:04 +0000 (18:37 +0200)
SOC:   Qualcomm Atheros QCA9558
RAM:   128MB
FLASH: 16MB (Macronix MX25L12845EMI-10G)
WLAN1: QCA9558 2.4GHz 802.11bgn 3SS
WLAN2: QCA9880 5GHz 802.11ac 3SS
LED:   Power, LAN1, LAN2, 2.4GHz, 5GHz
Serial:Next to SPI Flash,
       Pinout is 3V3 - GND - TX - RX (Square Pin is 3V3)
       The Serial setting is 115200-8-N-1

INSTALLATION:

1. Serve an OpenWrt ramdisk image named "ursus.bin".
   Set your IP-address to 192.168.100.8/24.
2. Connect to the serial. Power up the device and interrupt
   the boot process.
3. Set the correct bootcmd with
   > setenv bootcmd run bootcmd_1
   > saveenv
4. Run
   > tftpboot 0x81000000 ursus.bin
   > bootm 0x81000000
5. Wait for OpenWrt to boot up.
6. Transfer OpenWrt sysupdate image and flash via sysupgrade.

Signed-off-by: Markus Scheck <markus.scheck1@gmail.com>
Tested-by: David Bauer <mail@david-bauer.net>
[whitespace fix, renamed LED labels and SoC type fix]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_ocedo_ursus.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index e0b777da739a71ebee54f4d386130dadccb17c1f..e399210b2bc40425a1fb654d3e4e803056123ae9 100755 (executable)
@@ -79,7 +79,8 @@ ath79_setup_interfaces()
                ucidef_set_interfaces_lan_wan "eth1" "eth0"
                ;;
        devolo,dvl1200e|\
-       devolo,dvl1750e)
+       devolo,dvl1750e|\
+       ocedo,ursus)
                ucidef_set_interface_lan "eth0 eth1"
                ;;
        dlink,dir-825-b1)
index 8766862bb639ade133e977f8e09d2183091c784b..bfddb5f1c3113660120613a5780a10824c5c1f43 100644 (file)
@@ -119,7 +119,8 @@ case "$FIRMWARE" in
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac_crc $(mtd_get_mac_text board_data 2176)
                ;;
-       ocedo,koala)
+       ocedo,koala|\
+       ocedo,ursus)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(mtd_get_mac_binary art 12)
                ;;
diff --git a/target/linux/ath79/dts/qca9558_ocedo_ursus.dts b/target/linux/ath79/dts/qca9558_ocedo_ursus.dts
new file mode 100644 (file)
index 0000000..1a92da3
--- /dev/null
@@ -0,0 +1,147 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9557.dtsi"
+
+/ {
+       compatible = "ocedo,ursus", "qca,qca9558";
+       model = "OCEDO Ursus";
+
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wifi2 {
+                       label = "ursus:green:wlan2g";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wifi5 {
+                       label = "ursus:green:wlan5g";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+       };
+
+};
+
+&pcie1 {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&pll {
+       clocks = <&extosc>;
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x040000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "u-boot-env";
+                               reg = <0x040000 0x010000>;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x050000 0x740000>;
+                       };
+
+                       partition@790000 {
+                               label = "vendor";
+                               reg = <0x790000 0x740000>;
+                               read-only;
+                       };
+
+                       partition@ed0000 {
+                               label = "data";
+                               reg = <0xed0000 0x110000>;
+                               read-only;
+                       };
+
+                       partition@fe0000 {
+                               label = "id";
+                               reg = <0xfe0000 0x010000>;
+                               read-only;
+                       };
+
+                       art: partition@ff0000 {
+                               label = "art";
+                               reg = <0xff0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&art 0x06>;
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy1: ethernet-phy@1 {
+               reg = <1>;
+       };
+
+       phy2: ethernet-phy@2 {
+               reg = <2>;
+       };
+};
+
+&eth0 {
+       status = "okay";
+       mtd-mac-address = <&art 0x00>;
+       phy-handle = <&phy1>;
+       pll-data = <0xa6000000 0x80000101 0x80001313>;
+
+       gmac_config: gmac-config {
+               device = <&gmac>;
+
+               rxdv-delay = <3>;
+               rxd-delay = <3>;
+               txen-delay = <0>;
+               txd-delay = <0>;
+               rgmii-enabled = <1>;
+       };
+};
+
+&eth1 {
+       status = "okay";
+       mtd-mac-address = <&art 0x12>;
+       phy-handle = <&phy2>;
+       pll-data = <0x3000101 0x101 0x1313>;
+};
index 0d5ad171f1eb3a6cf877eb25928878b412559824..08d36f25d73ca43ebc9e83b87c2e58941134ee39 100644 (file)
@@ -501,6 +501,15 @@ define Device/ocedo_raccoon
 endef
 TARGET_DEVICES += ocedo_raccoon
 
+define Device/ocedo_ursus
+  ATH_SOC := qca9558
+  DEVICE_TITLE := OCEDO Ursus
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 7424k
+  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += ocedo_ursus
+
 define Device/openmesh_om5p-ac-v2
   ATH_SOC := qca9558
   DEVICE_TITLE := OpenMesh OM5P-AC v2