octeon: use new ext4/f2fs overlay support
[openwrt/staging/lynxis/omap.git] / include / rootfs.mk
index 90ee3126195d6c43a518c95a55036229d46886a3..f3ba33a2be03a5e7a09c0cee6b1f0bcf7b216dac 100644 (file)
@@ -37,6 +37,7 @@ endif
 opkg = \
   IPKG_NO_SCRIPT=1 \
   IPKG_INSTROOT=$(1) \
+  TMPDIR=$(1)/tmp \
   $(STAGING_DIR_HOST)/bin/opkg \
        --offline-root $(1) \
        --force-depends \
@@ -47,6 +48,9 @@ opkg = \
        --add-arch all:100 \
        --add-arch $(if $(ARCH_PACKAGES),$(ARCH_PACKAGES),$(BOARD)):200
 
+opkg_package_files = $(wildcard \
+       $(foreach dir,$(PACKAGE_SUBDIRS), \
+         $(foreach pkg,$(1), $(dir)/$(pkg)_*.ipk)))
 
 define prepare_rootfs
        @if [ -d $(TOPDIR)/files ]; then \