linux: add missing netfilter dependencies
[openwrt/staging/lynxis/omap.git] / package / kernel / linux / modules / netfilter.mk
index ed02a437f195e161ef4903d4c2eae10a4f80acd0..b8072a79c8a7aeabba2f0408477c127ed50279b7 100644 (file)
@@ -295,7 +295,7 @@ $(eval $(call KernelPackage,ipt-led))
 
 define KernelPackage/ipt-tproxy
   TITLE:=Transparent proxying support
-  DEPENDS+=+IPV6:kmod-ipv6
+  DEPENDS+=+kmod-ipt-conntrack +IPV6:kmod-ipv6 +IPV6:kmod-ip6tables
   KCONFIG:= \
        CONFIG_NETFILTER_TPROXY \
        CONFIG_NETFILTER_XT_MATCH_SOCKET \
@@ -315,6 +315,7 @@ $(eval $(call KernelPackage,ipt-tproxy))
 
 define KernelPackage/ipt-tee
   TITLE:=TEE support
+  DEPENDS:=+kmod-ipt-conntrack +IPV6:kmod-ipv6
   KCONFIG:= \
        CONFIG_NETFILTER_XT_TARGET_TEE
   FILES:= \
@@ -406,6 +407,7 @@ ARP_MODULES = arp_tables arpt_mangle arptable_filter
 define KernelPackage/arptables
   SUBMENU:=$(NF_MENU)
   TITLE:=ARP firewalling modules
+  DEPENDS:=+kmod-ipt-core
   FILES:=$(LINUX_DIR)/net/ipv4/netfilter/arp*.ko
   KCONFIG:=CONFIG_IP_NF_ARPTABLES \
     CONFIG_IP_NF_ARPFILTER \
@@ -423,6 +425,7 @@ $(eval $(call KernelPackage,arptables))
 define KernelPackage/ebtables
   SUBMENU:=$(NF_MENU)
   TITLE:=Bridge firewalling modules
+  DEPENDS:=+kmod-ipt-core
   FILES:=$(foreach mod,$(EBTABLES-m),$(LINUX_DIR)/net/$(mod).ko)
   KCONFIG:=CONFIG_BRIDGE_NETFILTER=y \
        $(KCONFIG_EBTABLES)
@@ -562,6 +565,7 @@ $(eval $(call KernelPackage,nf-conntrack-netlink))
 define KernelPackage/ipt-hashlimit
   SUBMENU:=$(NF_MENU)
   TITLE:=Netfilter hashlimit match
+  DEPENDS:=+kmod-ipt-core
   KCONFIG:=$(KCONFIG_IPT_HASHLIMIT)
   FILES:=$(LINUX_DIR)/net/netfilter/xt_hashlimit.ko
   AUTOLOAD:=$(call AutoLoad,50,xt_hashlimit)