try to load the orion glue automatically
[openwrt/staging/lynxis/omap.git] / package / kernel / linux / modules / usb.mk
index 47e337284a330fba8f6d9c193b95a057a29b1a22..96c899a8dd8e27326d025c505175e7b9a422564f 100644 (file)
@@ -394,7 +394,10 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
   FILES:= \
        $(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
        $(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
-  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform,1)
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
+  endif
+  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
 else
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko
   AUTOLOAD:=$(call AutoLoad,40,ehci-hcd,1)