bundle ehci-orion with kmod-usb2
[openwrt/staging/lynxis/omap.git] / package / kernel / linux / modules / usb.mk
index 47e337284a330fba8f6d9c193b95a057a29b1a22..9aa3e8c7028a6e1ec4cfe451b6ff699014172ffd 100644 (file)
@@ -394,6 +394,9 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
   FILES:= \
        $(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko \
        $(LINUX_DIR)/drivers/usb/host/ehci-platform.ko
+  ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
+    FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
+  endif
   AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform,1)
 else
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko