ccache, samba36: fix samba.org addresses to use https
[openwrt/staging/lynxis/omap.git] / package / network / services / samba36 / Makefile
index fdbaa65a7be93478da8a2ee2f0e00c7a3b7e5468..fcf772195ac369c12622d33b674ad3292bd6f887 100644 (file)
@@ -11,10 +11,10 @@ PKG_NAME:=samba
 PKG_VERSION:=3.6.25
 PKG_RELEASE:=5
 
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/stable
+PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
+               https://download.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=76da2fa64edd94a0188531e7ecb27c4e
+PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
@@ -34,7 +34,7 @@ define Package/samba36-server
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
   DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
@@ -42,7 +42,7 @@ define Package/samba36-client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
   DEPENDS:=+libreadline +libncurses
 endef
 
@@ -82,6 +82,7 @@ CONFIGURE_VARS += \
        samba_cv_USE_SETRESUID=yes \
        samba_cv_have_setreuid=yes \
        samba_cv_have_setresuid=yes \
+       ac_cv_header_libunwind_h=no \
        ac_cv_header_zlib_h=no \
        samba_cv_zlib_1_2_3=no \
        ac_cv_path_PYTHON="" \