iproute2: fix musl build
[openwrt/staging/lynxis/omap.git] / package / network / utils / iproute2 / Makefile
index e2f4b0218a151a3ab08710c6275ccc9881893554..0b9134e0c9d2b6dea1cf9aa88ce19aad61acf2f4 100644 (file)
@@ -81,6 +81,9 @@ ifdef CONFIG_USE_EGLIBC
     TARGET_CFLAGS += -DHAVE_SETNS
   endif
 endif
+ifdef CONFIG_USE_MUSL
+  TARGET_CFLAGS += -DHAVE_SETNS
+endif
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections