kernel: update to 2.6.32.10
[openwrt/staging/lynxis/omap.git] / target / linux / cobalt / patches-2.6.32 / 001-no_module_reloc.patch
index d871dd1376c2187c65e8b206657cd5c938bd3a8e..3b1f12427abeccbb60c9bf36296061086c9ae844 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN linux-2.6.32.7/arch/mips/Makefile linux-2.6.32.7.new/arch/mips/Makefile
---- linux-2.6.32.7/arch/mips/Makefile  2010-02-01 18:06:35.000000000 +0100
-+++ linux-2.6.32.7.new/arch/mips/Makefile      2010-01-29 00:06:20.000000000 +0100
-@@ -83,7 +83,7 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -85,7 +85,7 @@ all-$(CONFIG_BOOT_ELF64)     := $(vmlinux-64
  cflags-y                      += -G 0 -mno-abicalls -fno-pic -pipe
  cflags-y                      += -msoft-float
  LDFLAGS_vmlinux                       += -G 0 -static -n -nostdlib
@@ -10,10 +9,9 @@ diff -urN linux-2.6.32.7/arch/mips/Makefile linux-2.6.32.7.new/arch/mips/Makefil
  
  cflags-y += -ffreestanding
  
-diff -urN linux-2.6.32.7/arch/mips/include/asm/module.h linux-2.6.32.7.new/arch/mips/include/asm/module.h
---- linux-2.6.32.7/arch/mips/include/asm/module.h      2010-02-01 18:06:35.000000000 +0100
-+++ linux-2.6.32.7.new/arch/mips/include/asm/module.h  2010-01-29 00:06:20.000000000 +0100
-@@ -9,11 +9,6 @@
+--- a/arch/mips/include/asm/module.h
++++ b/arch/mips/include/asm/module.h
+@@ -9,11 +9,6 @@ struct mod_arch_specific {
        struct list_head dbe_list;
        const struct exception_table_entry *dbe_start;
        const struct exception_table_entry *dbe_end;
@@ -25,10 +23,9 @@ diff -urN linux-2.6.32.7/arch/mips/include/asm/module.h linux-2.6.32.7.new/arch/
  };
  
  typedef uint8_t Elf64_Byte;           /* Type for a 8-bit quantity.  */
-diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/kernel/module.c
---- linux-2.6.32.7/arch/mips/kernel/module.c   2010-02-01 18:06:35.000000000 +0100
-+++ linux-2.6.32.7.new/arch/mips/kernel/module.c       2010-01-29 00:06:20.000000000 +0100
-@@ -43,117 +43,6 @@
+--- a/arch/mips/kernel/module.c
++++ b/arch/mips/kernel/module.c
+@@ -43,117 +43,6 @@ static struct mips_hi16 *mips_hi16_list;
  static LIST_HEAD(dbe_list);
  static DEFINE_SPINLOCK(dbe_lock);
  
@@ -146,7 +143,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
  void *module_alloc(unsigned long size)
  {
  #ifdef MODULE_START
-@@ -169,99 +58,21 @@
+@@ -169,99 +58,21 @@ void *module_alloc(unsigned long size)
  
        return __vmalloc_area(area, GFP_KERNEL, PAGE_KERNEL);
  #else
@@ -248,7 +245,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
        return 0;
  }
  
-@@ -284,36 +95,28 @@
+@@ -284,36 +95,28 @@ static int apply_r_mips_32_rela(struct m
        return 0;
  }
  
@@ -301,7 +298,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
  {
        if (v % 4) {
                pr_err("module %s: dangerous R_MIPS_26 RELArelocation\n",
-@@ -322,31 +125,17 @@
+@@ -322,31 +125,17 @@ static int set_r_mips_26(struct module *
        }
  
        if ((v & 0xf0000000) != (((unsigned long)location + 4) & 0xf0000000)) {
@@ -336,7 +333,7 @@ diff -urN linux-2.6.32.7/arch/mips/kernel/module.c linux-2.6.32.7.new/arch/mips/
  static int apply_r_mips_hi16_rel(struct module *me, u32 *location, Elf_Addr v)
  {
        struct mips_hi16 *n;
-@@ -611,32 +400,11 @@
+@@ -611,32 +400,11 @@ int module_finalize(const Elf_Ehdr *hdr,
                list_add(&me->arch.dbe_list, &dbe_list);
                spin_unlock_irq(&dbe_lock);
        }