imx6: fix image boot ubifs compression option
[openwrt/staging/lynxis/omap.git] / target / linux / imx6 / image / Makefile
index 2cd257d0a49b330e0a1abef34dd529c171d1134c..2c170582506fd7af33c635794c82e768c49fd46b 100644 (file)
@@ -34,7 +34,7 @@ define Build/boot-overlay
                $@.boot/6x_bootscript-$(DEVICE_NAME)
 
        $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
-               --space-fixup --force-compr=zlib --squash-uids \
+               --space-fixup --compr=zlib --squash-uids \
                $(MKUBIFS_OPTS) -c 8124 \
                -o $@.boot.ubifs -d $@.boot
 
@@ -84,22 +84,22 @@ define Device/ventana
        imx6q-gw54xx \
        imx6q-gw5400-a \
        imx6q-gw551x \
-       imx6q-gw552x
+       imx6q-gw552x \
+       imx6q-gw553x
   DEVICE_PACKAGES := kmod-thermal-imx kmod-sky2 kmod-usb-chipidea-imx kmod-usb-mxs-phy \
        kmod-sound-core kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
        kmod-can kmod-can-flexcan kmod-can-raw \
-       kmod-rtc-ds1672 kmod-gpio-pca953x kmod-hwmon-gsc kmod-eeprom-at24 \
+       kmod-hwmon-gsc \
        kmod-leds-gpio kmod-pps-gpio kmod-gw16083 \
        kobs-ng
   KERNEL += | boot-overlay
   IMAGES := nand.ubi bootfs.tar.gz
-  UBINIZE_OPTS :=
   UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
   IMAGE/nand.ubi := append-ubi
   IMAGE/bootfs.tar.gz := bootfs.tar.gz | install-dtb
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)
   PAGESIZE := 2048
-  BLOCKSIZE := 128KiB
+  BLOCKSIZE := 128k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB
 endef
 
@@ -109,7 +109,7 @@ define Device/ventana-large
   DEVICE_TITLE := Gateworks Ventana family (large NAND flash)
   IMAGES := nand.ubi
   PAGESIZE := 4096
-  BLOCKSIZE := 256KiB
+  BLOCKSIZE := 256k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB
 endef