fix apex compile on osx, suppress some build warnings
[openwrt/staging/lynxis/omap.git] / target / linux / ixp4xx / image / apex / Makefile
index 789d4f21312487a808c4e40ec6e41f042d4836c1..10621e766d02e6f629bb2c21cca08f01e8f75b9c 100644 (file)
@@ -19,6 +19,7 @@ PKG_SOURCE_URL:=ftp://ftp.buici.com/pub/apex/ \
 PKG_MD5SUM:=5feb7a05431e5e8a4aa36fb23347de8e
 
 include $(INCLUDE_DIR)/package.mk
+export GCC_HONOUR_COPTS=s
 
 define Build/Configure
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -30,6 +31,7 @@ endef
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
+               KBUILD_HAVE_NLS=no \
                ARCH=arm \
                all
 endef