kernel: update linux 3.8 to 3.8.13
[openwrt/staging/lynxis/omap.git] / target / linux / malta / Makefile
index bcd2526fa2e325e809a9f7689860411e01a2f1f9..2e74b3a9279b56561c81342a08804cab1b4060cd 100644 (file)
@@ -1,25 +1,23 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mipsel
 BOARD:=malta
 BOARDNAME:=MIPS Malta CoreLV board (qemu)
-FEATURES:=ramdisk
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
+SUBTARGETS:=le be le64 be64
+INITRAMFS_EXTRA_FILES:=
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.32.10
+LINUX_VERSION:=3.8.13
 
-include $(INCLUDE_DIR)/target.mk
+DEVICE_TYPE:=developerboard
 
-DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim
+include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build firmware images for MTI Malta CoreLV boards.
-endef
+DEFAULT_PACKAGES += wpad-mini kmod-mac80211-hwsim kmod-pcnet32
 
 $(eval $(call BuildTarget))