build: unify powerpc target cflags
[openwrt/staging/lynxis/omap.git] / target / linux / ppc44x / Makefile
index 629eab0361928e12ad2fc61011392a8a8ec8587b..6c48c019449f2532a94b08eb009a87f30f17dbea 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+FEATURES:=squashfs broken
+CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.2.11
+LINUX_VERSION:=3.10.12
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -23,4 +23,6 @@ define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.taishan"
+
 $(eval $(call BuildTarget))