e2fsprogs: update to 1.42.8, fixes a build error
[openwrt/staging/lynxis/omap.git] / tools / ccache / Makefile
index 9bc0b5901a5013bef55aefbd5e6438b54afb4010..aeac393051f4090203c228a368ee278171b98b4d 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,24 +8,31 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
 PKG_NAME:=ccache
-PKG_VERSION:=3.1.7
+PKG_VERSION:=3.1.9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://samba.org/ftp/ccache/
-PKG_MD5SUM:=80a698c22d0b06b19c88ac58e8d8b632
-PKG_CAT:=zcat
+PKG_MD5SUM:=522a6016bda56892653612bbdefff3e0
 
 include $(INCLUDE_DIR)/host-build.mk
 
-ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
-  define Host/Compile
-       $(MAKE) CC="$(HOSTCC_NOCACHE)" -C $(HOST_BUILD_DIR)
-  endef
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"
+
+define Host/Install/ccache
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+       $(CP) ./files/* $(STAGING_DIR_HOST)/bin/
+endef
 
+ifneq ($(strip $(shell which ccache >/dev/null && echo found)),found)
   define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)
   endef
+  define Host/Install
+       $(call Host/Install/Default)
+       $(call Host/Install/ccache)
+  endef
 else
   define Host/Prepare
   endef
@@ -34,6 +41,7 @@ else
   define Host/Compile
   endef
   define Host/Install
+       $(call Host/Install/ccache)
   endef
   define Host/Clean
   endef