target: sunxi: enable builtin crypto-hw module sun4i-ss
[openwrt/staging/lynxis/omap.git] / tools / dosfstools / Makefile
index ca4f284aa6c2401c036b5080aefc53a23888ce28..d637a3b4c2060442d5e673fb14b7037315b1c8f1 100644 (file)
@@ -1,5 +1,6 @@
-# 
-# Copyright (C) 2012-2014 OpenWrt.org
+#
+# Copyright (C) 2012-2015 OpenWrt.org
+# Copyright (C) 2016 LEDE-Project.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,25 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dosfstools
-PKG_VERSION:=3.0.26
+PKG_VERSION:=4.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=http://daniel-baumann.ch/files/software/dosfstools/
-PKG_MD5SUM:=45012f5f56f2aae3afcd62120b9e5a08
-
-include $(INCLUDE_DIR)/host-build.mk
+PKG_SOURCE_URL:=https://github.com/dosfstools/dosfstools/releases/download/v$(PKG_VERSION)/ \
+               http://fossies.org/linux/misc
+PKG_MD5SUM:=9037738953559d1efe04fc5408b6846216cc0138f7f9d32de80b6ec3c35e7daf
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="$(HOST_LDFLAGS)"
-endef
+HOST_FIXUP:=autoreconf
 
-define Host/Install
-       $(INSTALL_BIN) $(HOST_BUILD_DIR)/mkfs.fat $(STAGING_DIR_HOST)/bin/
-       $(LN) mkfs.fat $(STAGING_DIR_HOST)/bin/mkdosfs
-endef
+include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Clean
-       rm -f $(STAGING_DIR_HOST)/bin/mk{dosfs,fs.fat}
-endef
+ifeq ($(HOST_OS),Darwin)
+HOST_CFLAGS += -UHAVE_ENDIAN_H
+endif
 
 $(eval $(call HostBuild))