ar71xx: image: remove duplicate IMAGES definition
[openwrt/staging/lynxis/omap.git] / tools / libtool / Makefile
index 080689b8ac203dcfd9777cd33bd1b6f323e84e55..9fab8d94fd5957f48469fe6f834b1873bd4fc69f 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,11 +13,19 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
 PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
 
+HOST_BUILD_PARALLEL:=1
+
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_VARS += \
        lt_cv_sys_dlsearch_path=""
 
+define Host/Prepare
+       $(call Host/Prepare/Default)
+       (cd $(STAGING_DIR_HOST)/share/aclocal/ && rm -f libtool.m4 ltdl.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4)
+       (cd $(HOST_BUILD_DIR); $(AM_TOOL_PATHS) ./bootstrap)
+endef
+
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool