use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/staging/lynxis/omap.git] / tools / sstrip / Makefile
index b10a2523c3dd702890b743a5e959af49b922d11d..ea4c3e880f056ff3bb58da76d101c8e7e849dbde 100644 (file)
@@ -11,7 +11,7 @@ PKG_NAME:=sstrip
 include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
-       $(HOSTCC) $(HOST_CFLAGS) -I./include -include endian.h -static -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
+       $(HOSTCC) $(HOST_CFLAGS) -I./include -include endian.h $(HOST_STATIC_LINKING) -o $(HOST_BUILD_DIR)/sstrip src/sstrip.c
 endef
 
 define Host/Install