use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/staging/lynxis/omap.git] / tools / yaffs2 / Makefile
index 8615fd30e9fc7c888d60964498ea31e0dcbb0fec..afa9ab9985b51299a4b5859731889c127366392a 100644 (file)
@@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/yaffs2/utils \
-               CC="$(HOSTCC) -static" \
+               CC="$(HOSTCC) $(HOST_STATIC_LINKING)" \
                CFLAGS="$(HOST_CFLAGS) -include endian.h" \
                mkyaffs2image
 endef