kernel: update 4.0 to 4.0.9
authorJonas Gorski <jogo@openwrt.org>
Wed, 22 Jul 2015 12:51:04 +0000 (12:51 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 22 Jul 2015 12:51:04 +0000 (12:51 +0000)
Changelog:
 * https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.9

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46440

include/kernel-version.mk
target/linux/generic/patches-4.0/259-regmap_dynamic.patch
target/linux/generic/patches-4.0/810-pci_disable_common_quirks.patch
target/linux/generic/patches-4.0/921-use_preinit_as_init.patch

index 0a4243e8d0809ecf7e01d439711eb1a57037a174..e03590f03ab19267a84827dfbf3a5a2b6416b871 100644 (file)
@@ -3,11 +3,11 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .19
-LINUX_VERSION-4.0 = .8
+LINUX_VERSION-4.0 = .9
 LINUX_VERSION-4.1 = .3
 
 LINUX_KERNEL_MD5SUM-3.18.19 = a143f9421bd8413752609d0d771c2955
-LINUX_KERNEL_MD5SUM-4.0.8 = a99375dd855de00635e9ac8e62b0f8e6
+LINUX_KERNEL_MD5SUM-4.0.9 = 40fc5f6e2d718e539b45e6601c71985b
 LINUX_KERNEL_MD5SUM-4.1.3 = 96c2c77b1c54ba01cfd8fc2d13fbf828
 
 ifdef KERNEL_PATCHVER
index 1e80aa2f2c0f01017497cd3ad2b1631448425ce7..dd42895108567e26e1108f8fdbfdc1d1c0dc0660 100644 (file)
@@ -75,7 +75,7 @@
  #include <linux/mutex.h>
  #include <linux/err.h>
  #include <linux/of.h>
-@@ -2632,3 +2633,5 @@ static int __init regmap_initcall(void)
+@@ -2631,3 +2632,5 @@ static int __init regmap_initcall(void)
        return 0;
  }
  postcore_initcall(regmap_initcall);
index eee15517e0318a789773ea38cc1a3e61deb3f179..8f72637eecc7058d527be70e375960ee8d517fd4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/pci/Kconfig
 +++ b/drivers/pci/Kconfig
-@@ -64,6 +64,12 @@ config XEN_PCIDEV_FRONTEND
+@@ -68,6 +68,12 @@ config XEN_PCIDEV_FRONTEND
            The PCI device frontend driver allows the kernel to import arbitrary
            PCI devices from a PCI backend to support PCI driver domains.
  
index 16448a4162ca9fbb6ea8f3ebdafdecff49ca06da..d0aa29f145bf4a0d66ce46c5078e65c260200f81 100644 (file)
@@ -1,6 +1,6 @@
 --- a/init/main.c
 +++ b/init/main.c
-@@ -956,7 +956,8 @@ static int __ref kernel_init(void *unuse
+@@ -957,7 +957,8 @@ static int __ref kernel_init(void *unuse
                panic("Requested init %s failed (error %d).",
                      execute_command, ret);
        }