hostapd: update to version 2016-12-19
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 20 Dec 2016 19:07:30 +0000 (20:07 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 20 Dec 2016 20:35:56 +0000 (21:35 +0100)
Update to latest upstream HEAD:

- Refreshed all
- Fixes 2 regressions:
--> PeerKey: Fix STK 4-way handshake regression
--> PeerKey: Fix EAPOL-Key processing

Compile tested Full & Mini configs
Run-tested Mini config

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
package/network/services/hostapd/Makefile
package/network/services/hostapd/patches/300-noscan.patch
package/network/services/hostapd/patches/370-ap_sta_support.patch
package/network/services/hostapd/patches/380-disable_ctrl_iface_mib.patch
package/network/services/hostapd/patches/390-wpa_ie_cap_workaround.patch

index 9f7125205b8dfbeccd8a9fefc04ae103a55d4883..0c5e73240f55c077074a6ed2e5e0f4a92296631c 100644 (file)
@@ -7,16 +7,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hostapd
-PKG_VERSION:=2016-12-14
+PKG_VERSION:=2016-12-19
 PKG_RELEASE:=1
-PKG_REV:=aaa9c60bc29750f7c09685635b6811c8041663cc
+PKG_REV:=ad02e79d12fd70ed6bd5fbaf64001a2851e5bb7b
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://w1.fi/hostap.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
 PKG_SOURCE_PROTO:=git
-PKG_MIRROR_HASH:=6ee5b8a8b9361c1bc688c27441763bd28722ff6236d96954213fef291c5cf73e
+PKG_MIRROR_HASH:=f9d51709d199f37c07cc8023c4a7097cee30eb75cceff7de0dcc4ba8ac78b186
 
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 PKG_LICENSE:=BSD-3-Clause
index f5737f309aca8ffa3775f3444cb5425a8939ff36..9dc0f2c393775abb91eb727fc6d96d3fa7802c1e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/hostapd/config_file.c
 +++ b/hostapd/config_file.c
-@@ -2930,6 +2930,10 @@ static int hostapd_config_fill(struct ho
+@@ -2953,6 +2953,10 @@ static int hostapd_config_fill(struct ho
                }
  #endif /* CONFIG_IEEE80211W */
  #ifdef CONFIG_IEEE80211N
@@ -13,7 +13,7 @@
        } else if (os_strcmp(buf, "ht_capab") == 0) {
 --- a/src/ap/ap_config.h
 +++ b/src/ap/ap_config.h
-@@ -674,6 +674,8 @@ struct hostapd_config {
+@@ -681,6 +681,8 @@ struct hostapd_config {
  
        int ht_op_mode_fixed;
        u16 ht_capab;
index 6399d042d9236fe9cd0b2f93f3e7def7314b501f..03819b33725c399912443e1333c4f60e49a994ac 100644 (file)
  #include "drivers/driver.h"
  #include "eap_peer/eap.h"
  #include "wpa_supplicant_i.h"
-@@ -288,6 +289,10 @@ static void calculate_update_time(const
+@@ -290,6 +291,10 @@ static void calculate_update_time(const
  static void wpa_bss_copy_res(struct wpa_bss *dst, struct wpa_scan_res *src,
                             struct os_reltime *fetch_time)
  {
        dst->flags = src->flags;
        os_memcpy(dst->bssid, src->bssid, ETH_ALEN);
        dst->freq = src->freq;
-@@ -300,6 +305,15 @@ static void wpa_bss_copy_res(struct wpa_
+@@ -302,6 +307,15 @@ static void wpa_bss_copy_res(struct wpa_
        dst->est_throughput = src->est_throughput;
        dst->snr = src->snr;
  
                        break;
 --- a/wpa_supplicant/bss.h
 +++ b/wpa_supplicant/bss.h
-@@ -79,6 +79,10 @@ struct wpa_bss {
+@@ -80,6 +80,10 @@ struct wpa_bss {
        u8 ssid[SSID_MAX_LEN];
        /** Length of SSID */
        size_t ssid_len;
index c22bb7cec9c680eb1bd413db099db3f5942bcee3..1403fe0f43e7d81b4ef9f099ec833d5e7e8d2a87 100644 (file)
@@ -51,7 +51,7 @@
                if (wpa_s->ap_iface) {
                        pos += ap_ctrl_iface_wpa_get_status(wpa_s, pos,
                                                            end - pos,
-@@ -8943,6 +8943,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -9032,6 +9032,7 @@ char * wpa_supplicant_ctrl_iface_process
                        reply_len = -1;
        } else if (os_strncmp(buf, "NOTE ", 5) == 0) {
                wpa_printf(MSG_INFO, "NOTE: %s", buf + 5);
@@ -59,7 +59,7 @@
        } else if (os_strcmp(buf, "MIB") == 0) {
                reply_len = wpa_sm_get_mib(wpa_s->wpa, reply, reply_size);
                if (reply_len >= 0) {
-@@ -8950,6 +8951,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -9039,6 +9040,7 @@ char * wpa_supplicant_ctrl_iface_process
                                                      reply + reply_len,
                                                      reply_size - reply_len);
                }
@@ -67,7 +67,7 @@
        } else if (os_strncmp(buf, "STATUS", 6) == 0) {
                reply_len = wpa_supplicant_ctrl_iface_status(
                        wpa_s, buf + 6, reply, reply_size);
-@@ -9428,6 +9430,7 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -9517,6 +9519,7 @@ char * wpa_supplicant_ctrl_iface_process
                reply_len = wpa_supplicant_ctrl_iface_bss(
                        wpa_s, buf + 4, reply, reply_size);
  #ifdef CONFIG_AP
@@ -75,7 +75,7 @@
        } else if (os_strcmp(buf, "STA-FIRST") == 0) {
                reply_len = ap_ctrl_iface_sta_first(wpa_s, reply, reply_size);
        } else if (os_strncmp(buf, "STA ", 4) == 0) {
-@@ -9436,12 +9439,15 @@ char * wpa_supplicant_ctrl_iface_process
+@@ -9525,12 +9528,15 @@ char * wpa_supplicant_ctrl_iface_process
        } else if (os_strncmp(buf, "STA-NEXT ", 9) == 0) {
                reply_len = ap_ctrl_iface_sta_next(wpa_s, buf + 9, reply,
                                                   reply_size);
  {
 --- a/src/rsn_supp/wpa.c
 +++ b/src/rsn_supp/wpa.c
-@@ -2250,6 +2250,8 @@ static u32 wpa_key_mgmt_suite(struct wpa
+@@ -2252,6 +2252,8 @@ static u32 wpa_key_mgmt_suite(struct wpa
  }
  
  
  #define RSN_SUITE "%02x-%02x-%02x-%d"
  #define RSN_SUITE_ARG(s) \
  ((s) >> 24) & 0xff, ((s) >> 16) & 0xff, ((s) >> 8) & 0xff, (s) & 0xff
-@@ -2333,6 +2335,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
+@@ -2335,6 +2337,7 @@ int wpa_sm_get_mib(struct wpa_sm *sm, ch
  
        return (int) len;
  }
index fb7b9b200413df0b2e64a7c937d2a4c1bef8cf41..7f147aec1d97762a5e8e3711bc8b88abf16041ea 100644 (file)
@@ -1,6 +1,6 @@
 --- a/src/common/wpa_common.c
 +++ b/src/common/wpa_common.c
-@@ -1446,6 +1446,31 @@ u32 wpa_akm_to_suite(int akm)
+@@ -1445,6 +1445,31 @@ u32 wpa_akm_to_suite(int akm)
  }
  
  
@@ -32,7 +32,7 @@
  int wpa_compare_rsn_ie(int ft_initial_assoc,
                       const u8 *ie1, size_t ie1len,
                       const u8 *ie2, size_t ie2len)
-@@ -1453,8 +1478,19 @@ int wpa_compare_rsn_ie(int ft_initial_as
+@@ -1452,8 +1477,19 @@ int wpa_compare_rsn_ie(int ft_initial_as
        if (ie1 == NULL || ie2 == NULL)
                return -1;