kernel: update to kernel 3.10.1 and refresh patches
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 13 Jul 2013 22:45:09 +0000 (22:45 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 13 Jul 2013 22:45:09 +0000 (22:45 +0000)
SVN-Revision: 37275

include/kernel-version.mk
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/generic/patches-3.10/204-module_strip.patch
target/linux/generic/patches-3.10/531-debloat_lzma.patch
target/linux/imx23/Makefile
target/linux/imx6/Makefile
target/linux/ixp4xx/Makefile

index 96b2575aacecf8a80e8b68bc00e2302d53785524..0e7311b69d2b4ea91e4b5dbb501b4a380f0b9641 100644 (file)
@@ -17,8 +17,8 @@ endif
 ifeq ($(LINUX_VERSION),3.9.10)
   LINUX_KERNEL_MD5SUM:=2d69615f7074b952cfcb65f1356c0cc9
 endif
-ifeq ($(LINUX_VERSION),3.10)
-  LINUX_KERNEL_MD5SUM:=4f25cd5bec5f8d5a7d935b3f2ccb8481
+ifeq ($(LINUX_VERSION),3.10.1)
+  LINUX_KERNEL_MD5SUM:=4c8ed240943c8750a89cc307637bd74d
 endif
 
 # disable the md5sum check for unknown kernel versions
index ea3a3326bc0377a79d5b9ff21f97637916e82d2c..7fe31620542131d40115508fd8ca87c2f1af6152 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
 FEATURES:=squashfs usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.1
 
 include $(INCLUDE_DIR)/target.mk
 
index e4991477d9155a0009c67ead825ea052823ecf64..399fb80e672f32316889639f1642d1b896a89017 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Broadcom BCM2708/BCM2835
 FEATURES:=ext4 audio usb usbgadget display gpio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.1
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index 74a4254249682087e6e61e273b42af8a1ab67127..e4d5407c8e60f27f2d22bd06217b2b3f42091e5d 100644 (file)
@@ -78,7 +78,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  #ifdef MODULE
  #define __MODULE_INFO(tag, name, info)                                          \
  static const char __UNIQUE_ID(name)[]                                   \
-@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]                        
+@@ -23,8 +33,7 @@ static const char __UNIQUE_ID(name)[]
    = __stringify(tag) "=" info
  #else  /* !MODULE */
  /* This struct is here for syntactic coherency, it is not used */
@@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
  #endif
  #define __MODULE_PARM_TYPE(name, _type)                                         \
    __MODULE_INFO(parmtype, name##type, #name ":" _type)
-@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]                        
+@@ -32,7 +41,7 @@ static const char __UNIQUE_ID(name)[]
  /* One for each parameter, describing how to use it.  Some files do
     multiple of these per line, so can't just use MODULE_INFO. */
  #define MODULE_PARM_DESC(_parm, desc) \
index 9f9690f1876625853681c0edcfc5086dc85af52c..aa3c49801636fef05b5bcc429ce31feccb43ef44 100644 (file)
  /* LzmaDecode
 --- a/lib/lzma/LzmaDec.c
 +++ b/lib/lzma/LzmaDec.c
-@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p, 
+@@ -682,7 +682,7 @@ static void LzmaDec_InitRc(CLzmaDec *p,
    p->needFlush = 0;
  }
  
  {
    UInt32 dicSize;
    Byte d;
-@@ -935,33 +883,11 @@ static SRes LzmaDec_AllocateProbs2(CLzma
+@@ -935,7 +883,7 @@ static SRes LzmaDec_AllocateProbs2(CLzma
    return SZ_OK;
  }
  
 -SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
--{
--  CLzmaProps propNew;
--  RINOK(LzmaProps_Decode(&propNew, props, propsSize));
--  RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
--  p->prop = propNew;
--  return SZ_OK;
--}
--
--SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
 +static SRes LzmaDec_AllocateProbs(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
  {
    CLzmaProps propNew;
--  SizeT dicBufSize;
    RINOK(LzmaProps_Decode(&propNew, props, propsSize));
-   RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
+@@ -943,28 +891,6 @@ SRes LzmaDec_AllocateProbs(CLzmaDec *p,
+   p->prop = propNew;
+   return SZ_OK;
+ }
+-
+-SRes LzmaDec_Allocate(CLzmaDec *p, const Byte *props, unsigned propsSize, ISzAlloc *alloc)
+-{
+-  CLzmaProps propNew;
+-  SizeT dicBufSize;
+-  RINOK(LzmaProps_Decode(&propNew, props, propsSize));
+-  RINOK(LzmaDec_AllocateProbs2(p, &propNew, alloc));
 -  dicBufSize = propNew.dicSize;
 -  if (p->dic == 0 || dicBufSize != p->dicBufSize)
 -  {
 -    }
 -  }
 -  p->dicBufSize = dicBufSize;
-   p->prop = propNew;
-   return SZ_OK;
- }
+-  p->prop = propNew;
+-  return SZ_OK;
+-}
+ SRes LzmaDecode(Byte *dest, SizeT *destLen, const Byte *src, SizeT *srcLen,
+     const Byte *propData, unsigned propSize, ELzmaFinishMode finishMode,
 --- a/include/linux/lzma/LzmaEnc.h
 +++ b/include/linux/lzma/LzmaEnc.h
 @@ -31,9 +31,6 @@ typedef struct _CLzmaEncProps
  void MatchFinder_Construct(CMatchFinder *p);
  
  /* Conditions:
-@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p, 
+@@ -70,12 +65,6 @@ int MatchFinder_Create(CMatchFinder *p,
      UInt32 keepAddBufferBefore, UInt32 matchMaxLen, UInt32 keepAddBufferAfter,
      ISzAlloc *alloc);
  void MatchFinder_Free(CMatchFinder *p, ISzAlloc *alloc);
  {
    memmove(p->bufferBase,
      p->buffer - p->keepSizeBefore,
-@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder 
+@@ -97,22 +103,14 @@ void MatchFinder_MoveBlock(CMatchFinder
    p->buffer = p->bufferBase + p->keepSizeBefore;
  }
  
index c9c5bb92d732d78da3b6718d763c336d1c2b8b0a..6aefb45b154c99e8fff843e190481eeb3f18abb9 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale i.MX23 series
 FEATURES:=ext4 rtc usb gpio
 CFLAGS:=-Os -pipe -march=armv5te -mtune=arm926ej-s -fno-caller-saves
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.1
 KERNELNAME:="zImage dtbs"
 #DEPENDS:=+imx-bootlets
 
index 38a00165b69f4c72bbc63d366da11d2551eef98d..db8956fd91d8c10fc1fb701b056726d24b805b65 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=audio display gpio pcie usb usbgadget squashfs targz
 CFLAGS:=-Os -pipe -mtune=cortex-a9 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.1
 
 include $(INCLUDE_DIR)/target.mk
 
index 1eb1abb287dc13db25bb68ba276b187f57385776..8eed9489f9c2beee38f017552d01763a282c0a17 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10
+LINUX_VERSION:=3.10.1
 
 include $(INCLUDE_DIR)/target.mk