tools/squashfs(4): use $(HOSTCC) to avoid building with clang on recent mac os x...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 13 Jul 2012 23:18:15 +0000 (23:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 13 Jul 2012 23:18:15 +0000 (23:18 +0000)
SVN-Revision: 32706

tools/squashfs/Makefile
tools/squashfs4/Makefile

index 473c5265108e4815ace6ec940c1557686c9661c5..c6ad3dd1be363ee15fb3c0fcf70a3766cf8bcd7b 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               CC="$(HOSTCC)" \
                LZMAPATH=$(STAGING_DIR_HOST)/lib \
                mksquashfs-lzma unsquashfs-lzma 
 endef
index 04a5456f6c24cb876aeec9034297db842d465bb7..fff550234cd14896fd1e74c34b19f59baab27d32 100644 (file)
@@ -20,6 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               CC="$(HOSTCC)" \
                XZ_SUPPORT=1 \
                LZMA_XZ_SUPPORT=1 \
                XATTR_SUPPORT= \