include/make.mk: add support for ubinize-overlay.cfg
authorJohn Crispin <john@openwrt.org>
Thu, 3 Apr 2014 14:26:31 +0000 (14:26 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 3 Apr 2014 14:26:31 +0000 (14:26 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 40365

include/image.mk

index bc7e7dbd1b3e6c22ccbc869a5c738d3b2bb698e0..978858a32fe49b5c65053643134a4ae3a6800310 100644 (file)
@@ -130,6 +130,19 @@ ifneq ($(CONFIG_TARGET_ROOTFS_SQUASHFS),)
 endif
 
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
+    define Image/mkfs/ubifs/generate
+       $(CP) ./ubinize$(1).cfg $(KDIR)
+       ( cd $(KDIR); \
+               $(STAGING_DIR_HOST)/bin/ubinize \
+               $(if $($(PROFILE)_UBI_OPTS), \
+                       $(shell echo $($(PROFILE)_UBI_OPTS)), \
+                       $(shell echo $(UBI_OPTS)) \
+               ) \
+               -o $(KDIR)/root$(1).ubi \
+               ubinize$(1).cfg \
+       )
+    endef
+
     define Image/mkfs/ubifs
 
         ifneq ($($(PROFILE)_UBIFS_OPTS)$(UBIFS_OPTS),)
@@ -150,16 +163,8 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
        $(call Image/Build,ubifs)
 
         ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
-               $(CP) ./ubinize.cfg $(KDIR)
-               ( cd $(KDIR); \
-               $(STAGING_DIR_HOST)/bin/ubinize \
-                       $(if $($(PROFILE)_UBI_OPTS), \
-                               $(shell echo $($(PROFILE)_UBI_OPTS)), \
-                               $(shell echo $(UBI_OPTS)) \
-                       ) \
-                       -o $(KDIR)/root.ubi \
-                       ubinize.cfg \
-               )
+               $(call Image/mkfs/ubifs/generate,)
+               $(if $(wildcard ./ubinize-overlay.cfg),$(call Image/mkfs/ubifs/generate,-overlay))
         endif
        $(call Image/Build,ubi)
     endef