conntrack: enable support for netfilter conntrack zones
authorAlin Năstac <alin.nastac@gmail.com>
Thu, 19 May 2016 07:54:06 +0000 (09:54 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 24 May 2016 11:30:57 +0000 (13:30 +0200)
Storage of such zones is provided by a nf_ct_ext struct, hence conntrack
memory foot print will not be increased if zones are not used.

Signed-off-by: Alin Năstac <alin.nastac@gmail.com>
package/kernel/linux/modules/netfilter.mk

index a0a19b23a95fd0bb84e42605e08d540244115642..353de3e45b3515fab07024227dbbda762740e7a1 100644 (file)
@@ -68,6 +68,7 @@ define KernelPackage/nf-conntrack
   KCONFIG:= \
         CONFIG_NETFILTER=y \
         CONFIG_NETFILTER_ADVANCED=y \
+        CONFIG_NF_CONNTRACK_ZONES=y \
        $(KCONFIG_NF_CONNTRACK)
   FILES:=$(foreach mod,$(NF_CONNTRACK-m),$(LINUX_DIR)/net/$(mod).ko)
   AUTOLOAD:=$(call AutoProbe,$(notdir $(NF_CONNTRACK-m)))