base-files: add uci-defaults script to migrate sysctl.conf (#12196)
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Sep 2012 17:15:56 +0000 (17:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 17 Sep 2012 17:15:56 +0000 (17:15 +0000)
SVN-Revision: 33448

package/base-files/Makefile
package/base-files/files/etc/uci-defaults/migrate-sysctl [new file with mode: 0644]

index 50ad7d4a0c13a74315613fae0fdde123e9637fb6..13927528c0e5a093ea4b4288f08414c20315ffd4 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=115
+PKG_RELEASE:=116
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/uci-defaults/migrate-sysctl b/package/base-files/files/etc/uci-defaults/migrate-sysctl
new file mode 100644 (file)
index 0000000..2250c57
--- /dev/null
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+if [ ! -f "/rom/etc/sysctl.conf" ] || cmp "/rom/etc/sysctl.conf" "/etc/sysctl.conf"; then
+       exit 0
+fi
+
+fingerprint="$(md5sum /etc/sysctl.conf)"
+fingerprint="${fingerprint%% *}"
+
+if [ "$fingerprint" = "1b05ebb41f72cb84e5510573cd4aca26" ] || \
+   [ "$fingerprint" = "62deb895be1a7f496040187b7c930e4e" ]; then
+       logger -t migrate-sysctl "Updating sysctl.conf to use current defaults"
+       cp "/rom/etc/sysctl.conf" "/etc/sysctl.conf"
+fi
+
+exit 0
+