kernel: update linux 3.7 to 3.7.4
authorGabor Juhos <juhosg@openwrt.org>
Thu, 24 Jan 2013 17:08:37 +0000 (17:08 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Thu, 24 Jan 2013 17:08:37 +0000 (17:08 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 35318

13 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/ar71xx/Makefile
target/linux/cns21xx/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mpc83xx/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ramips/Makefile
target/linux/ramips/patches-3.7/101-rt288x_serial_driver_hack.patch
target/linux/rb532/Makefile
target/linux/x86/geos/target.mk

index 932f186f2f1444d08271fc325868ecf1068a8251..f3d8aeda6cfb037941f74acb269e78ea82b7daab 100644 (file)
@@ -8,8 +8,8 @@ endif
 ifeq ($(LINUX_VERSION),3.6.11)
   LINUX_KERNEL_MD5SUM:=3d602ad7f7984509c3e923a5ae90bc54
 endif
-ifeq ($(LINUX_VERSION),3.7.3)
-  LINUX_KERNEL_MD5SUM:=6b35fb08d229d4c6d246f27c7d475790
+ifeq ($(LINUX_VERSION),3.7.4)
+  LINUX_KERNEL_MD5SUM:=b34c31c954bebdfb568244dd3897e7c6
 endif
 
 # disable the md5sum check for unknown kernel versions
index 462de16de27016719bdbaebe6d3ab458011c506b..bf8fc986e885a719b06c3ae3e43690fa064a0461 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index 2a197eda5d13b94627e5223529c50db47ac3bb15..a5412b5a0299c8764aec3b63a8fcbf06b62a2351 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
index c13a1cb033c9f5f1e72a26d1cff83c51cf919105..7e56e91d3925fbf721b8b4fdfdf178f52e856db6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 74ba4f0320601eb0861b714ba1e1eaa22f0c02e7..eb07e39d1f333354b9697535a206cba5789d7c3e 100644 (file)
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
 SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
index da05f10ff4f4939303efb2fb4087619c50e96b32..78ba3e4af6c51a68b01dccc62f1dc520ccb5a01d 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 DEVICE_TYPE:=developerboard
 
index 5670439ea8bd10a07b71ddb2f7120b24cbce8b11..22223ebe2d2eab124974b8c084cc8a55b470618a 100644 (file)
@@ -13,7 +13,7 @@ CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 36c10b315625592f405dedc2a3045ef539c9e3aa..675681fe224122013155e1e668d806dc5b4e0012 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 9abd715853c749b1397c134aaaf07c7872c02e53..83fb0c387e8c71d6b926ddc4d0fd5e8e8481de22 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 
index 82d20b6a8eb42418a2253c7ef70693d28801af50..346eca63c8a3f2ee724c7901887dbb051d7ea6e7 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt288x rt305x rt3883
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 FEATURES:=squashfs
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
index 8bc33272fddee26cb98d410ad30f92cbbcc002aa..4269e86acb549b02a050e77cd977f0f61b706a36 100644 (file)
@@ -28,7 +28,7 @@
  
 --- a/drivers/tty/serial/8250/8250.c
 +++ b/drivers/tty/serial/8250/8250.c
-@@ -308,9 +308,9 @@ static void default_serial_dl_write(stru
+@@ -314,9 +314,9 @@ static void default_serial_dl_write(stru
        serial_out(up, UART_DLM, value >> 8 & 0xff);
  }
  
@@ -40,7 +40,7 @@
  static const u8 au_io_in_map[] = {
        [UART_RX]  = 0,
        [UART_IER] = 2,
-@@ -489,7 +489,7 @@ static void set_io_from_upio(struct uart
+@@ -495,7 +495,7 @@ static void set_io_from_upio(struct uart
                break;
  #endif
  
@@ -49,7 +49,7 @@
        case UPIO_AU:
                p->serial_in = au_serial_in;
                p->serial_out = au_serial_out;
-@@ -701,22 +701,19 @@ static int size_fifo(struct uart_8250_po
+@@ -707,22 +707,19 @@ static int size_fifo(struct uart_8250_po
   */
  static unsigned int autoconfig_read_divisor_id(struct uart_8250_port *p)
  {
@@ -78,7 +78,7 @@
        serial_out(p, UART_LCR, old_lcr);
  
        return id;
-@@ -842,7 +839,7 @@ static int broken_efr(struct uart_8250_p
+@@ -848,7 +845,7 @@ static int broken_efr(struct uart_8250_p
        /*
         * Exar ST16C2550 "A2" devices incorrectly detect as
         * having an EFR, and report an ID of 0x0201.  See
index a4f195ae4c5b203778846b2b8d9510499e9c687b..ab032e332f57e470a23ef8e5980b4a1b82f6d95a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci targz broken
 
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-madwifi kmod-input-rb532
index 53cef2ac8b0f63ecd5c87bc201d40c2edfcbf506..a45c07f638add460921c624bef9ca0821572b6cc 100644 (file)
@@ -21,7 +21,7 @@ DEFAULT_PACKAGES += \
             kmod-cpu-msr \
             soloscli linux-atm br2684ctl ppp-mod-pppoa pppdump pppstats \
             hwclock wpad flashrom tc
-LINUX_VERSION:=3.7.3
+LINUX_VERSION:=3.7.4
 CS5535_MASK:=0x0E000048
 
 CFLAGS += -march=geode -Os -mmmx -m3dnow -fno-align-jumps -fno-align-functions \