Revert the recent dependency and metadata scanning rework
authorFelix Fietkau <nbd@nbd.name>
Wed, 11 Jan 2017 18:47:33 +0000 (19:47 +0100)
committerFelix Fietkau <nbd@nbd.name>
Wed, 11 Jan 2017 18:48:09 +0000 (19:48 +0100)
This reverts the following commits:
fbe522d1204149b6c128d55e360bfc15fa8258e1
278ad007ee03c4455c3507322e34b0e3e6ec050d
863888e44f7a1fb1675a2e7a2eaabfec3561d2a2
96daf6352f6e04bc22789466cb5409b93fbec191
cfd83555fc4f0bab18a26f6812da18e64df46ff3

This seems to trigger some mconf bugs when built with all feeds
packages, so I will try to find a less intrusive solution before the
release.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/network/utils/comgt/Makefile
package/network/utils/umbim/Makefile
package/network/utils/uqmi/Makefile
package/system/mountd/Makefile

index 2b39de648a661e059f16f078f6020a7fc64979bd..9ddc61758fd961fd4f8ab4a7cfd4ab593ca429d9 100644 (file)
@@ -39,7 +39,7 @@ endef
 define Package/comgt-directip
 $(call Package/comgt/Default)
   TITLE:=Sierra Wireless Direct-IP support
-  DEPENDS:=+comgt +USB_SUPPORT:kmod-usb-serial +USB_SUPPORT:kmod-usb-serial-sierrawireless +USB_SUPPORT:kmod-usb-net +USB_SUPPORT:kmod-usb-net-sierrawireless
+  DEPENDS:=+comgt +kmod-usb-serial +kmod-usb-serial-sierrawireless +kmod-usb-net +kmod-usb-net-sierrawireless
 endef
 
 define Package/comgt-ncm
index 0c02f897ce045441309718d39b41f1c6eda4b66d..42d4b85eaa0a5ffd584543119d909b51192b7f7b 100644 (file)
@@ -21,7 +21,7 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/umbim
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=+libubox +USB_SUPPORT:kmod-usb-net +USB_SUPPORT:kmod-usb-net-cdc-mbim +wwan
+  DEPENDS:=+libubox +kmod-usb-net +kmod-usb-net-cdc-mbim +wwan
   TITLE:=Control utility for mobile broadband modems
 endef
 
index d559197bd36a72bc29069a84a681919b804393d0..41db1e7671bcb245b3155dd87e91439fc16e36b0 100644 (file)
@@ -22,7 +22,7 @@ define Package/uqmi
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=WWAN
-  DEPENDS:=+libubox +libblobmsg-json +USB_SUPPORT:kmod-usb-net +USB_SUPPORT:kmod-usb-net-qmi-wwan +wwan
+  DEPENDS:=+libubox +libblobmsg-json +kmod-usb-net +kmod-usb-net-qmi-wwan +wwan
   TITLE:=Control utility for mobile broadband modems
 endef
 
index 28172b3d7b07347331850df5f05539abaeb24c9d..6922f2f5a07754a41a86eec2efabfa6232fcc9a9 100644 (file)
@@ -23,7 +23,7 @@ define Package/mountd
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=OpenWrt automount daemon
-  DEPENDS:=+USB_SUPPORT:kmod-usb-storage +uci +kmod-fs-autofs4
+  DEPENDS:=@USB_SUPPORT +uci +kmod-usb-storage +kmod-fs-autofs4
   URL:=http://www.openwrt.org
 endef