base-files: don't enter failsafe if triggered by switch
authorLuka Perkov <luka@openwrt.org>
Mon, 11 Nov 2013 23:34:11 +0000 (23:34 +0000)
committerLuka Perkov <luka@openwrt.org>
Mon, 11 Nov 2013 23:34:11 +0000 (23:34 +0000)
Fixes failsafe issues with switches after r38725.

Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38770

package/base-files/Makefile
package/base-files/files/etc/rc.button/failsafe

index f0b2e37d5b03a848045164e10271b6a4cd580b66..31c6e984bc8f3e0d344751dba619ee858fd8723f 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=147
+PKG_RELEASE:=148
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index b372c04c4e700297b12d613c8abefffcc13414f0..bfad810428952a5431b58562cc4b22c78c8cae81 100755 (executable)
@@ -1,2 +1,3 @@
 #!/bin/sh
-echo ${BUTTON} > /tmp/failsafe_button
+
+[ "${TYPE}" = "switch" ] || echo ${BUTTON} > /tmp/failsafe_button