build: make NETGEAR_REGION optional in netgear-chk
authorJoseph C. Lehner <joseph.c.lehner@gmail.com>
Fri, 3 Mar 2017 14:37:01 +0000 (15:37 +0100)
committerMathias Kresin <dev@kresin.me>
Sun, 12 Mar 2017 08:28:19 +0000 (09:28 +0100)
This patch makes specifying NETGEAR_REGION optional, in which case
mkchkimage will default to region 1 (WW).

Signed-off-by: Joseph C. Lehner <joseph.c.lehner@gmail.com>
include/image-commands.mk

index c513f19d3a1244ae2d6cd692b0f2545b393bda1c..c1d89825a3bc383ac9200af2093867ba05f0960c 100644 (file)
@@ -49,7 +49,7 @@ define Build/netgear-chk
                -o $@.new \
                -k $@ \
                -b $(NETGEAR_BOARD_ID) \
-               -r $(NETGEAR_REGION)
+               $(if $(NETGEAR_REGION),-r $(NETGEAR_REGION),)
        mv $@.new $@
 endef