ramips: add support for the Senao/EnGenius ESR-9753 board
authorGabor Juhos <juhosg@openwrt.org>
Fri, 23 Dec 2011 14:27:10 +0000 (14:27 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 23 Dec 2011 14:27:10 +0000 (14:27 +0000)
Signed-off-by: Artur Wronowski <arteqw@gmail.com>
SVN-Revision: 29603

14 files changed:
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/ramips/base-files/etc/uci-defaults/leds
target/linux/ramips/base-files/etc/uci-defaults/network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt305x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt305x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c [new file with mode: 0644]
target/linux/ramips/files/drivers/net/ramips_esw.c
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/config-2.6.39
target/linux/ramips/rt305x/profiles/engenius.mk [new file with mode: 0644]

index e0a4a3921836ea41f864e8b71798ab342881eeb9..a150cc26d8f9da05731b5eecb16e97e7d81395a1 100755 (executable)
@@ -33,6 +33,9 @@ get_status_led() {
        dir-300-b1 | dir-600-b1 | dir-600-b2)
                status_led="d-link:green:status"
                ;;
+       esr-9753)
+               status_led="esr-9753:orange:power"
+               ;;
        fonera20n)
                status_led="fonera20n:green:power"
                ;;
index d6db35c044f42d32212245a011a5adcfe5e40026..fa6607fd7fe8adf21a083e8639f5c299b0005f0a 100644 (file)
@@ -47,6 +47,7 @@ case "$FIRMWARE" in
 
        argus-atp52b | \
        bc2 | \
+       esr-9753 | \
        fonera20n | \
        hw550-3g | \
        mofi3500-3gn | \
index e6c7e8456e2af2f3a80347ec0a93b2c460134318..d0a9ac0711fa3bfa672953b267356ef31dfb4730 100755 (executable)
@@ -16,12 +16,29 @@ commit system
 EOF
 }
 
+set_wifi_led() {
+       local sysfs="$1"
+
+       uci batch <<EOF
+set system.wifi_led=led
+set system.wifi_led.name='wifi'
+set system.wifi_led.sysfs='$sysfs'
+set system.wifi_led.trigger='netdev'
+set system.wifi_led.dev='wlan0'
+set system.wifi_led.mode='link rx tx'
+commit system
+EOF
+}
+
 board=$(ramips_board_name)
 
 case $board in
        bc2)
                set_usb_led "bc2:blue:usb"
                ;;
+       esr-9753)
+               set_wifi_led "rt2800pci-phy0::radio"
+               ;;
        fonera20n)
                set_usb_led "fonera20n:amber:usb"
                ;;
index f78f9bf9dcf0e7bf3fe201c617f655ef53afe46a..bb1d90ef483246ca754c6ea68b0d9290c5a54d60 100755 (executable)
@@ -68,6 +68,7 @@ ramips_setup_macs()
                wan_mac=$(/usr/sbin/maccalc add "$lan_mac" 1)
                ;;
 
+       esr-9753 | \
        nbg-419n)
                 lan_mac=$(ramips_get_mac_binary factory 4)
                 wan_mac=$(ramips_get_mac_binary factory 40)
index 0518b7be9476b651e08f49a4bb3557fa9aa07ce5..eade567c3943a2ce458129378c939ae4d42b4462 100644 (file)
@@ -8,7 +8,7 @@ preinit_set_mac_address() {
        . /lib/ramips.sh
 
        case $(ramips_board_name) in
-       bc2 | nw718)
+       bc2 | nw718 | esr-9753)
                mac=$(ramips_get_mac_binary factory 4)
                mac=$(maccalc or "$mac" "02:00:00:00:00:00")
                ifconfig eth0 hw ether $mac 2>/dev/null
index 7d45bde096a2c7fe5bedc23229f9b956299e0ba7..faed42162cdae4a5beabb34969b958fb45d94349 100755 (executable)
@@ -62,6 +62,9 @@ ramips_board_name() {
        *"DIR-600 B2")
                name="dir-600-b2"
                ;;
+       *"ESR-9753")
+               name="esr-9753"
+               ;;
        *"F5D8235 v2")
                name="f5d8235-v2"
                ;;
index 211f72c5bc72a656d68133c0b64f24e64c5e2502..4076d6c500e29b69304a78b822c91573b5630219 100644 (file)
@@ -27,6 +27,7 @@ enum ramips_mach_type {
        /* RT3052 based machines */
        RAMIPS_MACH_ARGUS_ATP52B,       /* Argus ATP-52B */
        RAMIPS_MACH_BC2,                /* NexAira BC2 */
+       RAMIPS_MACH_ESR_9753,           /* Senao / EnGenius ESR-9753*/
        RAMIPS_MACH_F5D8235_V2,         /* Belkin F5D8235 v2 */
        RAMIPS_MACH_FONERA20N,          /* La Fonera 2.0N */
        RAMIPS_MACH_HW550_3G,           /* Aztech HW550-3G */
index cf8ede3b6bba955147e30502678e4ed4aeba896f..3e58242161d3b8ba4977b60c7c08a136941790be 100644 (file)
@@ -31,6 +31,11 @@ config RT305X_MACH_DIR_300_REVB
        select RALINK_DEV_GPIO_BUTTONS
        select RALINK_DEV_GPIO_LEDS
 
+config RT305X_MACH_ESR_9753
+       bool "EnGenius ESR-9753 support"
+       select RALINK_DEV_GPIO_BUTTONS
+       select RALINK_DEV_GPIO_LEDS
+
 config RT305X_MACH_FONERA20N
        bool "La Fonera20N board support"
        select RALINK_DEV_GPIO_BUTTONS
index be3d308f2dda70215d12686409b25b1418860727..5da73155f9d73509130fc649789dc827ba13e908 100644 (file)
@@ -14,6 +14,7 @@ obj-$(CONFIG_EARLY_PRINTK)            += early_printk.o
 obj-$(CONFIG_RT305X_MACH_ARGUS_ATP52B) += mach-argus-atp52b.o
 obj-$(CONFIG_RT305X_MACH_BC2)          += mach-bc2.o
 obj-$(CONFIG_RT305X_MACH_DIR_300_REVB) += mach-dir-300-revb.o
+obj-$(CONFIG_RT305X_MACH_ESR_9753)     += mach-esr-9753.o
 obj-$(CONFIG_RT305X_MACH_F5D8235_V2)    += mach-f5d8235-v2.o
 obj-$(CONFIG_RT305X_MACH_FONERA20N)    += mach-fonera20n.o
 obj-$(CONFIG_RT305X_MACH_HW550_3G)     += mach-hw550-3g.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c b/target/linux/ramips/files/arch/mips/ralink/rt305x/mach-esr-9753.c
new file mode 100644 (file)
index 0000000..88043a0
--- /dev/null
@@ -0,0 +1,123 @@
+/*
+ *  Senao / EnGenius ESR-9753 board support
+ *
+ *  Copyright (C) 2011 Artur Wronowski <arteqw@gmail.com>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev-gpio-buttons.h>
+#include <asm/mach-ralink/dev-gpio-leds.h>
+#include <asm/mach-ralink/rt305x.h>
+#include <asm/mach-ralink/rt305x_regs.h>
+
+#include "devices.h"
+
+#define ESR_9753_GPIO_LED_POWER                8
+#define ESR_9753_GPIO_LED_WPS          14
+
+#define ESR_9753_GPIO_BUTTON_WPS       0       /* active low */
+#define ESR_9753_GPIO_BUTTON_RESET     10      /* active low */
+
+#define ESR_9753_BUTTONS_POLL_INTERVAL 20
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition esr_9753_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "u-boot-env",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0a0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x150000,
+               .size   = 0x2b0000,
+       }, {
+               .name   = "firmware",
+               .offset = 0x050000,
+               .size   = 0x3b0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data esr_9753_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(esr_9753_partitions),
+       .parts          = esr_9753_partitions,
+#endif
+};
+
+static struct gpio_led esr_9753_leds_gpio[] __initdata = {
+       {
+               .name           = "esr-9753:orange:power",
+               .gpio           = ESR_9753_GPIO_LED_POWER,
+               .active_low     = 1,
+       }, {
+               .name           = "esr-9753:orange:wps",
+               .gpio           = ESR_9753_GPIO_LED_WPS,
+               .active_low     = 1,
+       }
+};
+
+static struct gpio_button esr_9753_gpio_buttons[] __initdata = {
+       {
+               .desc           = "reset",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .threshold      = 3,
+               .gpio           = ESR_9753_GPIO_BUTTON_RESET,
+               .active_low     = 1,
+       }, {
+               .desc           = "wps",
+               .type           = EV_KEY,
+               .code           = KEY_WPS_BUTTON,
+               .threshold      = 3,
+               .gpio           = ESR_9753_GPIO_BUTTON_WPS,
+               .active_low     = 1,
+       }
+};
+
+static void __init esr_9753_init(void)
+{
+       rt305x_gpio_init(RT305X_GPIO_MODE_GPIO << RT305X_GPIO_MODE_UART0_SHIFT);
+
+       rt305x_register_flash(0, &esr_9753_flash_data);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(esr_9753_leds_gpio),
+                                 esr_9753_leds_gpio);
+
+       ramips_register_gpio_buttons(-1, ESR_9753_BUTTONS_POLL_INTERVAL,
+                                    ARRAY_SIZE(esr_9753_gpio_buttons),
+                                    esr_9753_gpio_buttons);
+
+       rt305x_esw_data.vlan_config = RT305X_ESW_VLAN_CONFIG_WLLLL;
+       rt305x_register_ethernet();
+       rt305x_register_wifi();
+       rt305x_register_wdt();
+}
+
+MIPS_MACHINE(RAMIPS_MACH_ESR_9753, "ESR-9753", "Senao / EnGenius ESR-9753",
+            esr_9753_init);
index c681eed830e904238defe7224dda3b2d48ff1dc5..027284b084a418f3375f4ba87c9b4247e6f4b2bd 100644 (file)
 #define RT305X_ESW_REG_FPA2            0xc8
 #define RT305X_ESW_REG_FCT2            0xcc
 #define RT305X_ESW_REG_SGC2            0xe4
+#define RT305X_ESW_REG_P0LED   0xa4
+#define RT305X_ESW_REG_P1LED   0xa8
+#define RT305X_ESW_REG_P2LED   0xac
+#define RT305X_ESW_REG_P3LED   0xb0
+#define RT305X_ESW_REG_P4LED   0xb4
 
 #define RT305X_ESW_PCR0_WT_NWAY_DATA_S 16
 #define RT305X_ESW_PCR0_WT_PHY_CMD     BIT(13)
@@ -227,6 +232,13 @@ rt305x_esw_hw_init(struct rt305x_esw *esw)
        rt305x_esw_wr(esw, 0x3f502b28, RT305X_ESW_REG_FPA2);
        rt305x_esw_wr(esw, 0x00000000, RT305X_ESW_REG_FPA);
 
+       /* Force Link/Activity on ports */
+       rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P0LED);
+       rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P1LED);
+       rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P2LED);
+       rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P3LED);
+       rt305x_esw_wr(esw, 0x00000005, RT305X_ESW_REG_P4LED);
+
        rt305x_mii_write(esw, 0, 31, 0x8000);
        for (i = 0; i < 5; i++) {
                /* TX10 waveform coefficient */
index 4f92d30ecd543000a2d675e73963eff623540327..12487854d5e4acecf2ca2c638d303de2dd38d8a3 100644 (file)
@@ -162,6 +162,10 @@ define Image/Build/Profile/RTG32B1
        $(call Image/Build/Template/RTG32B1,$(1),rt-g32-b1,RT-G32-B1)
 endef
 
+define Image/Build/Profile/ESR9753
+       $(call Image/Build/Template/GENERIC_4M,$(1),esr-9753,ESR-9753)
+endef
+
 define Image/Build/Profile/FONERA20N
        $(call Image/Build/Template/GENERIC_8M,$(1),fonera20n,FONERA20N)
        $(call BuildFirmware/Edimax,$(1),fonera20n,RSDK,NL1T,0x50000,0xc0000)
@@ -253,6 +257,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/ARGUS_ATP52B,$(1))
        $(call Image/Build/Profile/BC2,$(1))
        $(call Image/Build/Profile/DIR300B1,$(1))
+       $(call Image/Build/Profile/ESR9753,$(1))
        $(call Image/Build/Profile/RTG32B1,$(1))
        $(call Image/Build/Profile/FONERA20N,$(1))
        $(call Image/Build/Profile/V22RW2X2,$(1))
index e3553e1efb3f799533743fbd359837301f41aa0f..2a5473dfb22cc1e0c08910c050596db940e18d9c 100644 (file)
@@ -94,6 +94,7 @@ CONFIG_RAMIPS_WDT=y
 CONFIG_RT305X_MACH_ARGUS_ATP52B=y
 CONFIG_RT305X_MACH_BC2=y
 CONFIG_RT305X_MACH_DIR_300_REVB=y
+CONFIG_RT305X_MACH_ESR_9753=y
 CONFIG_RT305X_MACH_F5D8235_V2=y
 CONFIG_RT305X_MACH_FONERA20N=y
 CONFIG_RT305X_MACH_HW550_3G=y
diff --git a/target/linux/ramips/rt305x/profiles/engenius.mk b/target/linux/ramips/rt305x/profiles/engenius.mk
new file mode 100644 (file)
index 0000000..09c716e
--- /dev/null
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ESR9753
+       NAME:=EnGenius Profile
+       PACKAGES:=
+endef
+
+define Profile/ESR9753/Description
+       EnGenius profile.
+endef
+$(eval $(call Profile,ESR9753))